How on earth do I fix this physics interaction?

So I have a gun which spawns bullets when you fire and they are supposed to simply deal damage to any other players/characters you damage that have the “Damagable” tag. The problem I am running into is that when the bullets hit, they’re doing this:

I don’t want them to push the character around like that. My bullets have a box collision component that spans across the Y axis because of the 2D nature of the game. Makes it easier to hit things that way. I need it to where the bullets simply deal damage then despawn entirely.

I’ve tried disabling the “Apply Impulse on Damage” under the Physics section of the bullet and the players. I have tried messing with the collision settings. Nothing seems to be working.
Here’s the physics properties for the Bullet:

and the properties for the player:

I should note that the bullets not doing anything unless they’re aimed at the bottom of the body is also not intentional and something I need to fix.
Any/all help would be very much appreciated. Thanks!

Collision component presets to OverlappAll and your Mesh component to no collision should fix your problem.


I eventually found my own sort of solution. I set the collision of the actor dealing the damage (the projectile/bullet) to Overlap all and the collision of the actor receiving the damage (player sprite) to block all (except visibility and camera). THEN I replaced the “Event Hit” event in the bullet’s event graph with an “Event ActorBeginOverlap” event and plugged it in accordingly. I get the desired result (bullets hit enemy target, deal damage, then disappear. no bullet surfing physics behavior).