How may I resolve an error "Couldn't find target rules file for target 'ProjectName' when building a project?

Hello, I have just started a new project using Unreal Engine 4.18 with nearly nothing in the project and had added a few C++ files to the project. These C++ files worked well in the previous versions of Unreal Engine. Every time I try to compile them I get the following log message and have no idea how to solve this one. I have found a few other posts on the same subject, but nothing relating to the issue dealing with Unreal it self. Please, will some one help me out with this. Here is a copy of the full log I receive.

ERROR: Couldn’t find target rules file for target ‘AyselKeep’ in rules assembly ‘UE4Rules, Version=, Culture=neutral, PublicKeyToken=null’.

   Location: C:\Program Files\Epic Games\UE_4.18\Engine\Intermediate\Build\BuildRules\UE4Rules.dll
   Target rules found:
    UE4Editor - C:\Program Files\Epic Games\UE_4.18\Engine\Source\UE4Editor.Target.cs
    UE4Game - C:\Program Files\Epic Games\UE_4.18\Engine\Source\UE4Game.Target.cs
    UnrealHeaderTool - C:\Program Files\Epic Games\UE_4.18\Engine\Source\Programs\UnrealHeaderTool\UnrealHeaderTool.Target.cs

In your Source directory, there needs to be a “target” file for each build type you want (that means whether it’s building the editor, game, or a server).

If you need an example, you can create a template project and look in that source. The files will be marked *.Target.cs.

If it worked before then those files must not have gotten copied over somehow. If they’re gone for good you can recreate them by copying from a template project and renaming the files/classes so they match your project name.


That was very helpful. Thanks for the info, well pleased with your help. :smiley:

I had this issue when creating projects on one of my computers. For some reason projects created on one of the computers create the following setting in the .uproject file (just open it with a text editor):

“Enterprise”: true,
I removed the setting from the .uproject file and now it compiles.

Although I don’t know why, it solved my problem perfectly!

This solved it for me too!

Fixed it for me, too. Enterprise means that you have Unreal Studio access.

Thank you guys for offering some assistance here. Next issue with this part I am dealing with is, what do I do if there is no “Enterprise”: true, located in any part of my codes? So far I have not located this yet even while using the search option to help locate it.

this is in the uproject file itself. Which should be quite clear. Just right-click on your uproject and openit with a text editor. Beware that this is not always the correct solution. If you dont have Enterprise = true set, there could still be other problems with your project that lead to failed packages.

This solved my problem perfectly! Thank you so much.

yep! solved!

+1 for being the solution. I came here from a project started in the SpatialOS branch of UE and back to the main branch. I guess by default they set their projects to Enterprise.

Tnx!!! Helped me with my project as well.

that helped me as well.
Thank you

Not sure if this is relevant to you anymore, but for the record the issue turned out to be I was using “BluePrintReadOnly” with private variables. Once i moved them to the public that fixed the build issue.