How is this possible?

I had a large map and I wanted to find out what was causing the large size so I created a copy and started deleting stuff from the map until I found what was causing the huge file size. I couldn’t find it. In the end I deleted everything that was in the map and it is still somehow showing at 500+MB. If you take a look at the below picture you can see its empty. There is nothing in the level blueprint yet somehow the map is still over 500 MB in size. How can that be it is quite literally empty?

c7c5e2304f9a4e14a5f9803198e8d8d54093ab16.jpeg

I suppose that it might be carrying the map history, and maybe it’s material compilation info pre done I guess.

Also it could be the map gets “bloated” I noticed that substance painter will increase your file size for each save, even if you made trivial changes.

But there are no materials in there. There is nothing in there its an empty level.

Old lightmaps?
Try to rebuild the light and see if it’s still 500mb.

(I’m not sure how they’re saved, just a guess.)

Or navmesh data?

There are no lights in there so I can’t rebuild a light. Same for navmeshs. There is none there.

This kind of nonsense is exactly why we need text based assets… noone can tell you what is wrong inside these uasset/umap things.

yeah but maybe old lightsmaps from building or Navmesh data before you removed the lights / Navmesh?

I did a complete rebuild and its the same size. This is a really strange one.

If you check your map uasset through pc browser, how much it has? My maps had around 30 mb…
It may be incorrect file size…

Unreal Engine is Bloatware. 500 megs for saving an empty level with nothing at all in it is ridiculous… What has it got an invisible Sky Sphere? But even Sky Spheres don’t take up this much space. It should only be about 1-2 megs in size the map file when saved with a sky sphere, not be 500 megs. But this engine also creates tons of extra file assets. Its bad news because all these extra files that it is generating from textures to create materials slows down systems. It may have a compiler to compile all the assets, but it don’t have a Packer, It dosen’t even pack all the sound files up into an audio pack file which can be decompressed when loaded into memory since my game has got thousands of audio dialog files…

It dosen’t do the same for the models or for the textures. Would be easier if all the assets of the game during the build were just compiled into resource pack files instead of just cooking everything in their own separate directories. And all you do is just put your assets into the resource pack files. The file management in Unreal at the moment is poor. You can’t always move things over to different folders if you are in a different directory hireachy in the content browser so I suppose you have to use Explorer instead to move the asset over to the directory you want. The Blueprint’s suspectibility to Node Corruption is also rather problematic… That’s why you don’t use migrate to copy over any blueprints from an existing project into an another project because if you do, it just breaks the blueprints and causes non access and other errors to appear in the code or causes trouble with the pins. But
migrating assets from an existing project appears to be the only thing that works without breaking something.

Its annoying when Unreal Engine dosen’t bother to put in a default lightmap if you import in a model that has got no lightmap. There should be an option to select a lightmap for your model and bake it
on. Not counting all the plugins that have been made for it, Unreal Engine BY itself has got no 3d modeling tools, there’s only a humanoid rig, there’s no creature rigs to target, and no auto rigger
for those who don’t know how to rig models. Everything has to be either assembled up from scratch
or brought from the marketplace… Unreal Engine is also very hands on manual…

The engine also should not be crashing on you if you accidentally select the wrong skeleton when creating a anim Blend space or other asset. The engine should just tell you the skeleton is the
wrong one and alow you to cancle or reselect another skeleton but The engine dosen’t even wait
for the user to hit cancle or correct if they make a mistake in their choice, it just tries to hard
code the changes instead of waiting for the user to cancle or correct. which causes the
engine to crash because its not waiting for the user.

IN BUILT DIALOGUE SUBTITLE SYSTEM

I also don’t think the dialog subtitle system is very good if you have to create an audio file for
every single line of subtitle text, or the subtitle text won’t display anything, again this
creating too many files. I don’t like that system, They should allow the subtitle system to
still display the text without the audio file, for sometimes subtitle text has no audio or you
may not want audio to play for every single subtitle text in the game.

So how did they do it in Mass Effect or Kotor to put in tens of thousands of Dialog Lines
using this built in subtitle text system if there’s no option to read in the data rows table
in the text subtitle system for the lines of dialog?

This engine also breaks down too easily so its rather fragile. And if you have a map with many assets
on it and it begins to slow down. For some reason these 3d engines can’t handle rendering alot of
items in one place which is why they have to use level streaming to hide things on layers.

Engine content…
And starter content, doesn’t matter if it is used in a level or not, it will take space

I deleted it now but I was checking in my project folder in My Documents at the same time and it was showing a slightly less size there by a few MB.

Well this probably explains why the map files get so big.

You probably need to save the project and reload it for the file sizes to show the correct value.

I did that believe me I tried everything. There is nothing in there but it was still over 500 MB in size. I haven’t tried it with any other maps but you could probably try yourself and get the same result.

When you package it, if it is empty it should have around 50 - 100 Mb.