Download

How Hide Crosshair in Menu and sound problems

Hello community,

I’am beginner in UE.

I have created a new level in first person and a widget to create a menu. This level is name “Level_Menu”.
I have created a new level, name “Level01”, this level is first person too. Nothing in this level, just ligths and character (basic content).

On this menu i have an image in background, 3 buttons (New Game, End Game and Options).

My problem, when i click outside the buttons, i hear the sound of fire gun.
Another thing, when i click play and launch the game i see the crosshair in the first second because i’ve made a animation faddind in the 3 fist seconds when i launch the menu.

How can i remove the crosshair during play menu and the sounds ??

In attachment the Graph Blueprint Menu.

Thanks a lot for your time.

The gun noise is because the default level has a guy with a gun in it. You need to go into the character BP and disconnect the fire action ( node called on input fire, or something like that ).

The crosshair you can get rid of by removing it from the default HUD ( or you can just delete the default HUD BP ).

Ok, but if i do that, when i’am going to load the first level, my crosshair will disappear and i would no longer have the fire sound of the gun, it’s correct ?

but i want to keep the crosshair and gun sound in the first level.

Thanks

One thing that you can do is remove the player start from the level and place a camera actor in the level and set that to auto possession since you have the widget menu. Also, in the level BP if you set up “disable input” and connect it to the player controller and player character, it should prevent the gun fire from happening. Now if you also use “set cinematic mode” that may also help. With that you can hide the player, the player UI and disable the movement and turning of the player. And when you call the widget into the level for the menu, use “set input mode to UI” will set the mouse to only apply input to the UI and not the player, also set the “show mouse cursor” node in there and set it to true. I would test these out and see which one works better for you. Then in the first level that you have load, you would “set input mode to game” and then “enable input” and use the “set cinematic mode” node and allow the movement, UI, show player and turning. Since you are a beginner the nodes are in between the quotation marks, right click in the BP screen and type the names in. If you are confused still, let me know which one you are trying and I’ll try to explain where it’s NOT confusing. Haha

Hello,

Thanks a lot for your help.
It is working.
In my level menu BP, after “Event Begin” i have link “set cinematic mode” and all is good (crosshair and sound disappear).

Now i have another problem.
I have created a bag with items that i can stack, but when i open the bag, the cursor appear, the crosshair stay on screen and the movement of the camera is always actived.
Before using an item like a potion, i must do a first click and then i can click on my potion and use it…
i try to use the “set cinematic mode”, it’s working but when i go back in game (close the bag), no longer have the crosshair and the movement of the camera.

Thanks