how enable nat panch in EU4 when using steam online subsystem?

how enable nat panch in EU4 when using steam online subsystem? now “multiplayer shootout” example work fine over internet in 4.8.0 and find steam sessions, but if hosting PC behind NAT (don’t have public IP) i can’t connect

when i performed test i had 2 PC, one with public IP and other without

p.s. downloading last source code to check what bAllowP2PPacketRelay=true does from DefaultEngine.ini, more on steam nat punch here Steam Networking (Steamworks Documentation), but not so much to get idea how use it even with raw C++, maybe it just k_EP2PSendUnreliable, maybe not

yeah i was right, this is what source code says about AllowP2PPacketRelay:

// Allow P2P connections to fall back to being relayed through the Steam servers if a direct connection
// or NAT-traversal cannot be established. Only applies to connections created after setting this value,
// or to existing connections that need to automatically reconnect after this value is set.
//
// P2P packet relay is allowed by default

so it doesn’t work for any reason, i will try check what “TCP view” will show

packaged multiplayer shootout win32, not that project was upgraded from 4.7.6 to 4.8.0 in editor win32 with steam upgraded from 4.7.6.rar — Yandex Disk and not just raw 4.8.0 from learn tab at launcher

also i found that leaving game to bring up main menu hang on, so i’ll try check log

just quote:

“when i performed test i had 2 PC, one with public IP and other without”

so it’s about 2 PC and about different steam users - yes, i used different and one client can connect to another, but not otherwise, because PC without public IP

i have to note, that in spacewar (steamworks example game) i could connect to my second PC without public IP, but i did it after “create lobby” and “find lobby”

so even invite friend to game worked on PC without public IP and second PC could connect in spacewar (but only when spacewar wasn’t running on second PC, because seems invites with running game doesn’t handled properly