Download

How does unreal tournament prevent weapons from penetrating static meshes?

I have been seeing a lot of talk on the problem of weapons penetrating walls and everything else for that matter, but no solutions to the problem.
Nothing anyone tries or suggests is working.

When I play Unreal Tournament and Paragon this is not an issue, it all works perfectly. I have looked around the forums and can’t find the solution.
Perhaps I didn’t look hard enough or didn’t use the right search strings, though I have been working on fixing this issue for several days.

My question is, how does Epic set things up to address the issue of weapons penetrating static meshes with the games they produce?

Maybe they use render texture with flags on the weapons or modified the renderer for the game and didn’t share.
There’s now a node in capture2d where you can hide actors, but I guess they’ve created one that hides everything by default and adds only the weapon to the texture instead if they do use these render textures…

Adding collision is something I have used. Be careful with collision shapes that are children of other collision shapes , stuff happens.

Adding collisions in any traditional sense is ineffective. The forums around the internet are full of those solutions and none of them work.
Perhaps an Epic developer could chime in? Please?
Id really be interested in how its done in the games Epic produces. Everyone wins with high quality production of 3rd party games.
Perhaps in the next update of the Unreal Editor they can address the issue by default. Or, create a training video for just this sort of thing?

I was wondering this myself.

Browsing the UT project aint helpfull either. So massive, dont know where too look…

Okay I’m not sure how or why but when I deleted the first person character after messing up the settings and getting compile errors and put in a new first person character spawn, it now works exactly as it is supposed to but only with the static mesh I created, all the stock content still has issue with the gun penetrating map objects. When I nail down the cause and solution and can replicate my success I will post the results here.

Before I fixed running up ramps.- YouTube
After I fixed running up ramps.- YouTube
The meshes in the fixed map have the same identical settings between the ramps and the cube. Does anyone have an idea what might be going wrong?