How do you zoom into a really big object in your scene?

So I am new to Unreal, and I wanted to import a terrain from Blender into UE5. I was able to import the mesh just fine and place it into my scene, but I am not able to zoom in at all into it.
The mesh is REALLY big, but I did apply the scale/rotation in Blender (i.e. set the scale and rotation to 1,1,1).

Does anyone know what is wrong? Is the object’s sheer size preventing me from zooming in?

1 Like

Click the object and press F to focus it.
To zoom in hold down the right mouse button and press W or S, if you want to change the zoom speed use the mouse wheel.

If you set the scale to zero the object disappears, do you mean 1,1,1?


I already tried pressing F and using W and S to change the zoom speed. Unfortunately that didn’t change anything. I still can’t zoom into my terrain.

Yeah, sorry. I meant 1,1,1.

Are you holding down the right mouse button while you press them?
WASD keys are used to move around like in a videogame, can you please take a video to show what’s happening?


Here’s a video of what’s going on. I didn’t show it in the video (I forgot) but I also held tried pressing F to focus the object first.

Also, as I mentioned before, even though the scale is set to 1,1,1, the actual size of the object is really big. Here is a screenshot of the dimensions in Blender. Is it possible that is the problem?

Wow, that’s really strange! Can you share the FBX of the landscape? I’m really curious to see if the size is the mesh that causes the issue.

I noticed that you have camera speed set to 4 so it should be moving a little, if it works in other viewports it’s not a key-binding problem, you could try enabling distance-scaled camera speed:


Sure! Another thing to mention is that the mesh is a really high resolution.

Here’s a link to the FBX (Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.).


Hey! Just figured it out I think. If you go to Edit>Editor Preferences>Level Editor>Vieports>Controls>check off Distance Used Camera Speed, that seemed to help a lot. I’m able to ALT+RMB, RMB+W, and RMB+S and move smoothly in my scene.


I’m glad that you solved it! I’m downloading your mesh just to try if I have the same problem.

EDIT: I tried and It gives the same problem even in UE4, once you press F you are too far and the camera doesn’t respond if you don’t enable “Use distance-scaled camera speed”
Another solution is to select another object in the World Outliner and focus it pressing F, then you’ll be able to move regularly

Have a nice day!


I bet you are moving but you’re so far out it doesn’t look like it. Try putting a small object at world 0,0,0, press F to zoom to it then move around. Or increase the move speed in the top right corner from 4 to the max and use the mouse wheel to increase it further.