Download

How do you stop Windows Firewall from popping up repeatedly?

It’s not constant but about every three or four days I get yet another one. I should only have to check this box once not over and over.

Also asking Microsoft here.

I assume you’ve tried clicking the public box too in case when originally connecting to your Wifi point you indicated it was a public point.

Allowing access here should be making an exception in Defender, but you may wish to do it manually if not. Type “advanced” in the Start Menu, choose the Advanced Firewall, Inbound Rules and create a new one. Just give it a Name, enable it, Allow connection and on the Program and Services page, type the value you see under path in your above screenshot. (I find “Browse” can make the rule fail if the path has spaces in it.)