Download

how do you separate animations?!

greetings

I’m new to unreal, not to 3d or c++, and I’m having quite the time trying to get an fbx file to animate correctly in ue4

All of the help I’ve found refers to actorX, which I see is no longer a viable option - how do you seperate an fbx’s single timeline into animations Unreal can use?

I’ve been trying to get a character to animate according to player input for 2 days, and have been reduced into trying to animate a CUBE!

I spent some time reading through ue4 docs on animation blueprints, state machines, blend space etc but I am no closer to creating a cube moving from idle to forward off player input then i was 2 days ago

anyone else have this much trouble?

Where exactly are you running into problems? You’re able to import animations and assign them to a skeletal mesh, but unable to get them to play on player input? You are able to move the player around but it doesn’t play animations?

when I import animations, the only thing i have working is being able to see the animation playing when you dbl click on it - the problem is that there is only 1 single time range (0-1000 frames that contain the walk, run, idle, attack animations, etc…) so i can’t even move past this stage, let alone trying to get it to respond to any player input (which is the end goal)

don’t the animations inside the fbx file need to be separated into individual sections of animation inside the editor somehow?

You need to either separate them by exporting each range of frames to a separate FBX file or set the range when importing and import each one individually. You can’t break them up after importing.

Did you mean you can’t break them up after importing, or is there a way to do that? Regardless I’ve yet to come across an instance where all animations were clumped into one fbx.

Yes. Autocorrect has struck again! I fixed it.

thanks Jeff - my problem is that i don’t know how to separate the single timeline (while in ue4) into additional timelines. I also don’t know what to do after the timeline has been separated, but I’m hoping all that starts to make sense after i get this fbx file separated into its animations

basically, I have an fbx file with a bunch of character animation in it - now what

or is that not the correct unreal workflow

UE4 doesnt separate animations. Try to get the animations each in a separate FBX.

You can import the same file multiple times and select a frame range each time that matches the range for each particular animation. Or, you can re-export each one as an individual FBX file.

There is no way to do it afterward if you just import the whole file as a single animation.

so if I have a character with 30 animations I need to import the fbx file 30 times? So that would be 30 (geometry) + 30 (skeleton) + 30 (animation) + 30 (material) + 30 (w/e) files? then go through and delete all the extra material files etc? I’m trying to understand

I haven’t found how to properly set up a character using bp’s anywhere, let alone how to properly import an fbx that holds data for 30 different animations - im coming from unity and cryengine, this is a bit different

can someone share the workflow please?

also - I tried to open one of the animation files (the green files) and “attach” or “add” others to it but that didn’t seem to be the right way

It should be 1 SkeletalMesh, 1 Skeleton asset, 30 Animation Sequences, 1 set of Materials and Textures for the Skeletamesh, etc.

At Epic, we would have 1 FBX file for the Skeletalmesh (base pose, no animations). That would be imported to generate the SkeletalMesh and Skeleton assets. Then we would export 1 FBX file per animation sequence and import each of those individually. When importing animations, you choose Animation from the top of the import options dialog and select the Skeleton asset to associate them with. This should result in only a single Animation Sequence asset being generated.

You should be able to do something similar using a single FBX file, but you would import it over and over for each animation sequence and choose the range of frames to import.

You need to make sure you choose Animation at the top of the import options dialog or it will import as a SkeletalMesh. That is probably where the disconnect is occurring here.

Having applied multiple animations to a mesh, it was very easy. If you import all your animation fbx’s, you can assign them all to one skeleton.

I mean no disrespect, but I find it hard to believe you couldn’t find answers to these questions in the documentation or downloadable content examples.

Thanks, those are the same docs i read through (and more)

Jeff - Thanks a million, I now have multiple animations from the same fbx file on a single skeleton, which is exactly what i needed, now I can move on to the next step

The problem I’m having with these documents is that they tell you what something does on the surface, but give you no logic or understanding of how the things “they do” actually accomplish “what they do”

  • for example - the docs explain that the animation blueprints are where all of the data comes together to cause skeletal meshes to animate as you’d expect, but that’s all she wrote… there’s no real description (that I’ve seen) explaining the process - this is less than helpful to someone who has never used kismet or is new to anything other than set dressing an unreal environment

  • another - the docs say to import the skeletal mesh and “Make sure that Import Animation is enabled”, when in fact what I had to do, thanks to Jeff’s direction, was to import a skeletal mesh with zero animation, then import animations onto that skeletal mesh one by one

so you can see my confusion - I’m going to try and get this character walking now that I have all the animations in ue4 on the same actor. I’ll post other issues in this thread if they’re similar or relevant

thanks again

There are two sections in the documentation under Importing Animations. The first explains how you can import the SkeletalMesh and Animation sequence together. The second (which is the one you want) explains how to import individual animations.

Regardless, there are some errors in the documentation that are being fixed up as we speak, and I have brought this to the attention of the tools team so they can try to make the tools more intuitive and helpful surrounding this process.

You can also break up a single long imported sequence using animation composites in the editor, though the workflow isn’t ideal. Check out this thread for more information:

https://answers.unrealengine.com/questions/20990/create-multiple-animation-clips.html

Cheers,
Michael Noland

Sorry to revive this thread 2 years later. But I have the same problem and the given solution doesn’t work in UE 4.13

I import the fbx file with it’s mesh, without animations.
then I import again deselecting “import mesh” and setting the skeleton to the one from previous import
I enable import animations, put it to “Set Range”, fill in the range of the first animation
I hit import and i get the following error:

Error Asset with same name exists. Can’t overwrite another asset

Also in UE 4.13 I can’t choose animation on top, it seems the workflow has changed, so i have to deselect import mesh to only export the animations, but then i get the error

any ideas?

thanks in advance

Edit: I found a way to work around the error. Just renaming the file to the new animations name i.e. Character_Idle.fbx did the trick. Then I chose Set Range and set the frames range and it worked :slight_smile: