Download

How do you render still images for archviz?

Ohkay, so it has been a few months since I started working in Unreal and I am happy with my current quality level. My levels look sharp with good lighting that is splotch free and without artefacts but whenever I take screenshots, they come out with lower quality than the editor. I have tried the console command and inserting a Cam (not cinecam) in the sequencer but they also give me lesser quality than the editor. No matter if I take a 1080p shot or even a 8k. They lack the details that are otherwise visible in the editor and gameplay.
Any ideas how to take high quality renders like those I see on Unreal Seminar videos?

There are lots of ways to take screenshots. This is the way I take them if I want to save the angle and location of the camera:

  • Place a cinematic camera and name it
  • move your viewport camera to the spot you want to take the screenshot from
  • right click the cine camera in the world outliner and select ‘snap object to view’
  • then ‘pilot’ the camera from the world outliner as before
  • go to the details panel of the cine camera and adjust the Camera Settings like a real life camera: Focus Distance, Focal Length and Aperture. You can also tweak the Post Process settings in there like exposure if you want to.
  • fine tune the position of the camera by using your normal viewport controls
  • open the ‘High Resolution Screenshot’ menu in the viewport
  • Set your multiplier and take the screenshot. I usually use a multiplier of 2 which is twice your viewport resolution. That’s good enough for web presentation but you might want to increase that number for prints. Be careful as a high number more than 5 or so might crash the editor. So save before trying.
  • At the end ‘eject’ the camera from piloting so you don’t accidentally move it.

Next time you want to take a screenshot search for the camera in the world outliner, pilot it and then take the screenshot again. Hope that helps

Thanks for the reply. After I tried some screenshots today with different methods and none of them giving me the crisp quality I wanted, I uploaded the file to my office sustem and gave it a shot. To my surprise, it did come out great.
After which I came to this conclusion that I need to upgrade my GPU cos I am running a GTX 960 while I have a RTX 2070 in my office PC.
Even after having a texturestreampoolsize of 2000, my office system runs out of memory. Might have to optimise the scene. But then again, I barely have 6-7 master materials and 30-40 material instances. Also no texture is more than 2k. Don’t know where I am going wrong.

I have never found that a screenshot solution to work.

My own method has been to create a new level sequence just for still shots and render out a minimal frame count. Not ideal but gives me what I need.

Also if you are using Raytracing or anything dynamic you really need that warm up frame count. I’m sure someone will tell me there’s a much easier way!

Exact same situation here

You could try Bandicam, rather than using the in-editor tool: https://www.bandicam.com