Download

How do you re-calculate a phat asset?

Working in Blender and exporting-importing a model with animations. Then i get the error message “Bone size too small cannot create physics asset”. An answer from the Hub suggest to re-calculate the phat asset - how do you do this? Another guy explained how he used FBX Converter (3DSMAX i guess?) to make it work somehow, took him three days. But this doesn’t appear very straight forward.

Notice i scaled down the metrics in Blender to 0.010, according to this tutorial. Also scaling by 10 didn’t seemed to fix the error.

Anyone knows how to fix it or how to adjust settings? Thanks.

The phat asset
deaffb8169a1ad9caa1f15aafb89cddc2e1c643f.jpeg

An answer can be found here https://answers.unrealengine.com/questions/52944/problem-on-creating-physics-assert.html However, scaling up in Blender doesn’t fix the error.

Update
Ok, got it working with these settings. Scale in Blender is default = 1 no metric unit. And i think the scale does not matter in this case anyway.
761ff021494dacc9ea30da761773211877200460.jpeg

To sum this up. The main culprit seems to be the version FBX BINARY 7.4 (flawed?), with FBX ASCII 6.1 it went fine.

I have got a setup that will give you perfect PHAT assets here https://forums.unrealengine.com/showthread.php?62941-Blender-2-73a-and-2-74-working-export-to-UE4-settings-for-various-types

Today i noticed that the fix from above does not work with another model. You can still import with both FBX, but the collision physics are way off. A fix for that is to go into the physics asset and rescale the collisions manually.

did not have this problem myself. Probably an issue related to scaling

Hi there!

Did you figured it out? If not, I may be able to help you here.

The problem is on Blender.
UE uses the armature scale to build the rigid bodies on the physics asset. If it’s scale is too big, you will have problems moving and rescaling on the physics asset editor. I didn’t figured out how to change this value on UE editor, so I solved this problem on Blender before exporting.
The bone scale must be about 0.1 of the mesh (you can change it by selecting the armature on object mode and changing the scale on the properties window - hotkey N).
This is something you must do when building the skeleton, so… if you scale it now you will probably need to fix all the bones.
Then export again and you’ll see that the rigid bodies created on the physics asset will be smaller, and easier to work.
OBS: When importing you must set the Uniform Scale to the same you configured on the bone.

Hope I helped!

2.75 has this problem pretty much solved now.

I also had the “Bone size too small cannot create physics asset” error. Turns out… it’s probably a bug in Blender. There is a ticket for it and there is a workaround described:

https://developer.blender.org/T47043#366967

Best up to date setup tutorial series I have seen so far:

https://www.youtube.com/watch?v=LhWYwVPd2Oo