How do you Keystore in 4.25?

Ive followed all the info ive found on how to do it but i still get an error while packaging saying that the Keystore File is missing.

I still have not been able to figure this out after about a week. Does anyone have any ideas?

Omg, I just had the same question!

I just spent about 3 hours trying to find it, hold on, I might have a solution. Epic really needs to make this process a lot easier.

Hopefully someone knows that can advise us because I have yet to figure it out.

I found a workaround that I just tested out and it seems to work for me so far. Seems like the keystore file is the whole cause of the issue and the tool is nowhere to be found because of the newer Google Android Studio workflow in 4.25 so I would really like to know where that went as well.

But anyways, after mucking around with this for the last 3+ hours…

Basically I opened a shipping test build APK with Android Studio then I went to Build > Generate Signed APK > Choose APK (unless you happen to know how to upgrade their stupid gradle).

**…g#generate-key (use this to generate the keystore file only after opening your apk)…ing/index.html (use this to just reference things and see where to put it in your project) **

I have no idea why in the hell Epic thought going through Android Studio was such a great idea, it just made things tougher and there’s still tons of errors there too.

So anyways, ignore all that and Create New then you should see some familiar fields that match the keytool, fill those in, set the name, file location, just make sure to add the name .keystore at the end of your file then save it. You might get an error or few but I noticed that seems to be due to something else and the keystore file you need still generates so I think the errors are for otherwise and can be ignored or at least this is what has happened on my end so far.

Once you do all of that, make sure you switch to shipping build and tick For Distribution as well or google play will reject it. I just tested this with one of my latest games a few minutes ago and it was accepted by google play when I uploaded it!

Hopefully Epic will comment and advise or update their workflow for 4.25 to resolve this whole mess, it’s really irritating for sure.

What ive done is open Android Studio. Then create a new project because it can’t find my ue4 project. Then i make a Keystore for that and place it into my directory of my ue4 project. That is what was supposed to work according to a guide i was following.

Ah okay, I’ll have to try it that way to see, maybe it won’t give me any errors doing it that way.

I guess i don’t fully understand your method. I still can’t get it to see the keystore file is there.

Hmm, seems like we’ve both reached an impass in that case. I found I couldn’t seem to generate the Keystore File from the Build Menu if I used a blank project unless I accidentally overlooked it maybe lol. There’s still a lot I don’t know and have been slowly been trying to learn and figure out.

What don’t you understand with it to get the keystore file? Maybe I can try to help you get it working. I know this stuff can get frustrating.

Just use the Android studio as suggested by @Deygus . On open you can use anylze an APK. Go to Build -> Generate Signed. Push the button to create a new keystore, enter your preferences for passwords, locations, namings, and alias for the key etc. It will give an error that it could not sign the apk because ev. stuff is missing but that is ok and not needed. After that the file should be in the folder you specified. Then copy that file to you UE4 project into Build/Android/ . I renamed mine to game2.keystore. This I did enter in the Distribution signing section. Just the keystore name, the alias for the key and the store password. That should do it for you too.

that worked thank you

So do you just create your own keystore password?