How do you hide the white ball in the Viewport?

hi, just wondering how to get rid of the white ball in the viewport… doesn’t seem to be a way to hide it… and it serves no purpose as far as I can tell… it just gets in the way, I want to see the Blueprint Class I am making and the ball is super annoying to have in there… any suggestions?

You can set Editor Billboard Scale to 0 in the details panel while in the viewport or in BP editor > Components Tab > select Self and check out the details panel.


The white ball is the “DefaultSceneRoot” component. It essentially represents the origin of the actor’s transformation, rotation and scale values.

You cannot get rid of it but it can be replaced by a different component which you would like to be the root component instead. If this has no visual aspect you will not see it in the viewport. Keep in mind this new root will be unable to be moved or rotated!

Edit: Just saw Jacky’s answer, that one is definitely better as you won’t be messing around with the root component in an irreversible way.

thanks!! you just made my day…

ahh I see, I’m adding my own scene on top of it…but maybe I could use this one instead?

It’s up to you. You can even set an Arrow component as the root so that you can see which way the BP is facing in the level, and then add other components under it and rotate/relocate them as you wish.

good idea…thanks!

hi I have the same problem,
I have tried the way, but I didn`t success.

And I Delete all component except Camera,Floor,Light,
it still has a white ball…


Just as a note, the Editor Billboard Scale is under the Rendering category.

1 Like

It’s unfortunate that this is an actor wide setting, because the only other component I have is an “editor only” component that happens to be a billboard (which then can’t be a scene root).

My workaround was to set billboard scale to 0.01 and then the scale of the billboard component to 100.

A small issue is the z-fighting that occurs between the default root and your billboard, but at that size it can be ignored (or as I did, moved the billboard slightly, which does mean that you get a white pixel in the middle of it from certain angles).

1 Like

YES!!! In Edit/Editor Preferences, search for Billboard and make the scale .01. It all but dissappears and is no longer in the way! THANK YOU!