Download

How do you Hide the camera actor in blueprint viewport?

Hello all,

Not sure if this is in the right area or not, but how do you remove/hide a camera that is obscuring the view in the blueprints viewport?

Here is a picture of what I mean…

f6af7f2f71b74e7abe6cee4d4ec8e8efd860b6a4.png

Thanks!

I don’t know of an exact way to hide it but would be interested in knowing how. As a work around I typically just write down the x,y,z and move it out of the way then put it back. That or I’ll go into perspective mode and just move my view above my sprite.

Isn’t there a visibility setting? Not at home to check but I thought there was.

I wasn’t able to find a visibility setting in this viewport…

I have been moving it out of the way for now, it’s quite frustrating to have to work around assets like this though.

Yeah I have exactly the same problem also. I hope they going to add a feature to hide it.

is there not an option in the settings as visibility or visible in editor. maybe otherwise try use G to get into game view. this hides things like sprites (from sounds, BPs, or the x,y,z movement, scale, rotation).

1 Like

Cant you make it really small (scale it)? It should not affect its behaviour.

if im not much mistaken the camera is seen as a sprite and therefore not being able to scale it. for example if you start a blueprint there is always this white ball. when you get close, it will shrink to fit on your screen. you cant change how much the sphere does that. i think thats what cameras do as well.

Going with tukor’s suggestion: It is scaleable & using 0,0,0 doesn’t adversely affect game-time camera-view etc.
Game Mode isn’t applicable to BP Viewport & interestingly Cams don’t seem to be toggleable in the Editor either.
Weird Epic left it out of the Editor Viewport Show options when every other possible option appears to be there…

oh, sorry then, i thought it was a possibility. i could have known if i were at my desk right now, but im not

The camera’s a 3D model, you can find it in the engine folder. You could try modifying the material to make it translucent.

  1. Enable Engine Content
  2. In the Blueprint, select the mesh and in the mesh selector, click ‘clear’
  3. The Camera is invisible, if you wanna put it back just search matinee cam…it will only come if you have engine content.
    Hope this helps to all who come here in this future :smile: