How do you download Marketplace items for use in Linux?

First, thank you for providing the UE in Linux. I was pleasantly surprised to see that. I have built the UE Editor in Linux (PopOS based on Ubuntu 20.04) but am unable to download assets. I have access to a Windows machine and after logging in I see that instead of a Download button I have an “Add to Project” lbuton but the Engine is not installed there. How can I download the asset packs so they can be used in the UE in Linux?

Thanks!

2 Likes

I have a similar problem, in linux I have a download button but it does not work as xdg-open cannot access the link. I do not get an add to project button on linux and the only advice on marketplace help is to use unreal launcher which is not available for linux as far as I can see.

Faking existing local projects for Add-To-Project is easy, whereas getting plugins installed?! :mad:
How hard was it to get UE4 installed on Ubuntu anyway. Snap make things worse or better?

Not hard at all… just took some time to build. Followed these instructions. Just wish I can add assets in a straightforward manner.

Installing was simple, if time consuming, using the same instructions as linked by pcapazzi. But d/l of any content does not work, from Archlinux wiki The launcher with the Unreal Marketplace is not available for Linux yet, so apps like the ContentExamples project cannot be installed from Linux.

The marketplace apps can be downloaded using the launcher on Windows (or Mac)

This is of course not acceptable for linux users so it seems I need to use something like ue4-mp-downloader to get content into my projects

Ok so today I tried installing the Launcher using Wine. It installed but I ran into trouble when logging in.

I then saw a post that Lutris (lutris.net) has a script for Epic Games Store. After reviewing the script I see that it’s installing the launcher. I kept searching for Unreal Launcher so I missed it before. That install worked. I’m in the marketplace. I have the same options as if I’m in Windows which made me realize that I cannot seem to create a project (from Linux UE4Editor) that shows in the MarketPlace to add a content pack to. There is no login for the UE4 Editor… there is no option to link the Editor to an account… nor do I see the option in Project Settings. Creating and Saving Projects don’t show an option to upload it to Epic. It just seems like this executable (for Linux) is on it’s own.

So now… with Lutris’ install of the (Windows) Launcher I’m downloading the Unreal Engine (again). I’ll try and create a project with it and see if I have any better luck with it. AsEntrpriseCustomr mentioned I’ll probably try and create an empty project there and see if I can move the assets to Linux. Of course… then comes the question… what’s the point… you’ve now got a working (Windows) version of UE so why bother keeping the Linux one around? :-/

1 Like