Download

How Do You Create a Moving Flying Saucer?

I am Trying make a flying saucer that can just move on left, right, forwards, backwards, I have used a player controller class for this.

http://i1099.photobucket.com/albums/g386/sziada/Component_View_zpsa9c85ba7.png

I have set up a view camera for the saucer and also a box to encapsulate the saucer for collisions

http://i1099.photobucket.com/albums/g386/sziada/Graph_View_zpsba3f6223.png

This is my Blueprint for the movement

http://i1099.photobucket.com/albums/g386/sziada/ProjectSettings_zpsaa978496.png

here are my project settings.

I could really use some help getting my head around these blue prints please feel free to leave suggestions and mock ups down below

Download the ‘Content Examples’ assets from the Marketplace and load up the Blueprints (Keyboard Input) (I think that’s the one) level.

It has a demo of a fully working flying saucer with a jet propulsion boost and the ability to pick up and drop cows and trees. Looking through the blueprints that make that system work might help you.

Edit: I’m not on a computer with UE4, so some of the names above could be wrong.

Hey, while the setup you have can work (it needs some modifications :slight_smile: ) it might just be easier to do it a way I found while watching through various Blueprint videos on youtube. Set up your axis, with ‘forward’ being 1 and ‘back’ being -1, relative to each axis. Then, instead of trying to make a vector just right click, type “Control” and drop a “Get Control Rotation” node, then click the node line and drag it out (for contextual results) and type in “Get”, and you should see the Get Forward/Right/Up Vector nodes. Drop down the Forward and Right nodes, as those vectors will also work perfectly fine for Backwards and Left vectors if you’ve set the appropriate scale to -1. Now right-click, type “add movement input”, drop that node, and plug in the appropriate wires, and you should be good to go!

edit: Its worthwhile to note that in my Defaults tab in the blueprint editor (it may also be found under the components tab if the proper component is selected) I turned off Gravity. Also, if you want it to be restricted from moving up or down, you might want to restrict its movement in the vertical plane so things don’t become misaligned.

Here’s a picture of my setup for reference.

https://dl.dropboxusercontent.com/u/17693891/Temp_Example.png