Download

How do you build&package for Directx 10?

Hi all,

I’m having trouble with the package settings,
I’ve got a simple 2d sprite thing I made for a friend so he could see his sprites running around, but he’s got a fairly old pc which complained about him not having directx 11.

So I went into the settings in the Unreal project and changed to Directx 10, pressed cook content and re-packaged it and it’s complaining that I don’t have the right cooked content and should try an uncooked build.

To be honest I’m now lost, I don’t know what steps I might have missed as I’ve never played with these settings before, and I don’t know what settings I’d change for an uncooked build either.

Can anyone point me on the right track?

I had that error trying to run the exe from the projects directory, You may have to use the package command.

HTH

I’m not sure what you mean by package command, I’ve already packaged the content for windows, if that’s what you mean?

I’ve seen two commands that you could have used: Cook content, Package (menu).

You could try checking if the D3D10 shaders are generated and present, But you will need to disable the option that packs the cooked content together.

I’ve done the cook content, then packaged.
There’s a pixel and vertex shader in ‘Engine\Shaders\StandaloneRenderer\D3D’

But I don’t have a ‘GlobalShaderCache-PCD3D_SM5’ folder, which is what it says it’s looking for.

Are you using a feature that relies on D3D11?

I may have access to a machine that only has upto D3D10 support to test.

I’m not sure.
I wouldn’t have thought so, as it’s just 2d sprites, Is there any way to check?

I don’t know, I’ve seen some nodes in the material editor that require HLSL5 features to work.
Have you tried posting to Answerhub ? (There may be more people who could help there)