Download

How do we delete old references?

I deleted a couple of skeletal meshes which I forgot were referenced as preview meshes in my characters hands. Now when I try to open his skeleton/or animation tab the editor crashes.

I tried reimporting the deleted meshs but I get this message ’Failed to delete… The asset is referenced by other content."

Is there a way dig into the character and remove these references? I found the ‘reference viewer’ and can see the dead nodes but I can’t deleted them in there sadly.

Thanks for any help.

Well UE4 likes to leave bread crumbs when you do things like moving assets from one folder and deleting others so as to maintain continuity UE4 creates a redirect. This way if you merge or migrate an asset from one project to the one your working on the asset can find where something has been moved to or has been deleted. This tends to create error messages like name in is already in use or in your case the asset is being referenced by another.

Most cases right clicking on the folder you can select “Fix Up Redirectors in Folder” and you will be given a list of dependencies along with the option for force delete.

Thanks for the info Frankie. Good to know that ‘Fix Up Redirectors’ option is there. Sadly it didn’t help in this situation so I bit the bullet and rebuilt the item.

Redirectors weren’t the problem here. Never delete files from outside the editor. When you delete files inside the editor, it will first prompt you with all the references to it so you can set them to other values before removing the asset, to avoid references to assets that no longer exist.

One of my standard tasks before I do a commit to my source code repository or stop development for the evening is to run a “Fix Up Redirectors”. I then also check the physical folders to make sure I have no lurking redirectors. This has saved me countless headaches … but as Furyhunter pointed out … always delete/move your assets inside the editor.

For me, it worked. Since I had little files in my folders, I changed them to another folder and deleted the one which was having the problem. After deleting the folder, I created a new one with the same name and copied my contents back and it works fine.

I solved this problem closing the editor and after reopening it; unfortunately, i deleted all inside of the editor, by forcing it, that’s why i have

For me the problem was caused by Source Control that I forgot about :slight_smile:
If you’r using that, make sure you commited / reseted deleted items

What about renaming a whole bunch of files?
I get failed to load referenced by blah blah.
Fixing redirectors wont help in this case right?
I tried rebuild that didn’t work.
The game still works though no glitches it does find the new names.
Its just an annoying warning I keep getting when opening the project in the editor.

It works for renaming too my error is gone :slight_smile:

thanks, fixed for me too