How do i use Plugin in Source build Engine?

I am trying to use a Plugin with my source build Unreal Editor 4.19.2 …

I can use this Plugin in my Epic Launcher Unreal Editor 4.19.2. So i just copy&paste the Folder from /Plugins/Marketplace/Mathworks to the same path in my source build 4.19.2.

The Plugin: the Plugin is from MathWorks. For the Epic Launcer Editor it is also just copied&pasted to the Plugin Folder.

Thinks i tried (from other Forum Questions):

  • copy the plugin to the project folder
  • delete intermediate folder
  • copy the Plugin to the source Code Folder, run generateProjectFiles.bat and recompile the whole Engine again

Nothing worked. What am i missing. Pasting the same Plugin to the same Version doesnt work?

So source directory is in there? Also do you see those files visible in generate VS project?

Thanks for your reply.
I downloaded the (former Marketplace Plugin) from Matlab.

Epic Launcher 4.19.2: paste to UE_4.19/Engine/Plugins/Marketplace → works fine

Source Code 4.19.2: paste to UE_4.19/Engine/Plugins/Marketplace → cant load the plugin

It shows up in Visual Studio and in the Unreal Editor but i can not activate it in the Editor.
Here are some screenshots of the errors i get.



When check the Plugin box, the Editor needs to restart and i get the first 2 massages.

Hmm can you check the logs? maybe there some hints, there might be also issue with 3rd party dlls if that plugin use any. you mgiht try rebuilding engine and see if plugin actually builds.

There also other option, make C++ project, move plugin to project directory (yes you can do that), put Plugins/Marketplace inside project directory (if it does not work move plugin out of Marketplace directory to Plugins, refresh VS project files of oyur project and then rebuild, this will make plugin part of the project and allow you to focus on that plugin. If it will work you can move bineries to engine direcotry, they should work

Thank you for your advice. I needed some time to dig into this. I tried to rebuild the PLugin with a c++ project, but it didnt worked. I did:

  • create C++ Project ‘MyPluginProject’
  • Open VS2017 → analyze data → save&close
  • Cope Plugin to [Project]/[Plugins]
  • right click on [Project].uproject → Generate Visual Studio project files → works
  • open [project].sln
    → rebuild (took 50 min)

after finishing, i tried to open the project and the error appears:

The followimodules are missing or built with different engine version:
Would you like to rebuild them now?
→ error: [Project] could not be compiled. Try rebuilding from source

I tried many suggestions i found online like: delete Binaries/ Intermediate of the Plugin or the project or both. Nothing worked.
The new binaries are way smaller then the Original Binaries of the Plugin.

I think the *build.cs might be incomplete and the ThirdParty source is not included while generation. Also the directory structure is nothing like any other Plugins i found
The .h/.cpp files are all in the [Intermediate] folder instead of [Source]. Is this the Problem? Or does the Manufacturer not provide the Source code to the public?

Here is the solution,

  • Install the binary version of engine (Sadly this is inevitable, but you can install very very minimal one from custom settings)
  • Get the plugins from marketplace
  • Place them to sourcebuild path in Engine/Plugins/Marketplace
  • Go to root folder of source build and run GenerateProjectFiles.bat. (This may not necessary to have as a step, need to experiment)
  • Rebuild unreal engine
  • Go to edit and plugins, your plugins will be visible there, activate them.

There you go.