How do I unbind the AI debugging key (') for game instance?

Dear Friends at Epic,


Independent game instance from commandline


I am trying to write my chat system, but every time I press " ’ " (next to ENTER key on US keyboards)

the AI debugging starts and disables my character


How do i disable it?!!

It doesnt seem to be in baseinput.ini



PS: my unsuccessful attempt so far:

-DebugExecBindings=(Key=B,Command="ToggleSpeaking true | OnRelease ToggleSpeaking false")
-DebugExecBindings=(Key=F1,Command="viewmode wireframe", bIgnoreShift=True)
-DebugExecBindings=(Key=F2,Command="viewmode unlit")
-DebugExecBindings=(Key=F3,Command="viewmode lit")
-DebugExecBindings=(Key=F4,Command="viewmode detaillighting")
-DebugExecBindings=(Key=F5,Command="viewmode shadercomplexity")
-DebugExecBindings=(Key=Period,Command="RECOMPILESHADERS CHANGED",Control=True,Shift=True)

I took a quick look and there doesn’t seem to be an easy way to do this right now. Depending on your wants, there’s two code changes you could make.

If you just want it on a different key you can change the value set to DebugComponentKey in the constructor of UGameplayDebuggingControllerComponent. I’ll add a task to make this configurable.

If you want to just disable the AI debugging entirely you could make sure that in APlayerController::Possess the DebuggingController doesn’t get created (I’d probably just add a false && in to the if statement). I’ll also add a task for someone to consider whether the debugging controller should be easily disabled.

Okay thanks Marc! As always!

Mainly I wanted to bring it to your attention, as I wont be able to type in my chat system anything with " " marks till this is fixed :slight_smile:

But it is not that big of a deal right now, just something for next build :slight_smile:

#Potential Pull

By the way I sent you a PM on regular UE4 forum about a potential pull!

It is my CreateDirectoryRecursive function!

full details here