How do I stop the PIE from auto-connecting to the dedicated server

How can I stop the PIE from auto-connecting to the dedicated server when I hit play, I have gone all through the advanced settings, I’ve checked dedicated server, stand alone, etc but it always auto-connects. Any suggestions?

I’m having this same problem 3+ years later in UE 4.26. From what I’ve been able to find, there used to be a “Auto Connect to Server” checkbox in the Editor Preferences → Play → Multiplayer Options… It is not there anymore. Is there any solution for this?