How do I set up my camera with portrait orientation?

I’m currently working on a mobile project with an orthographic camera which is meant to be played with portrait orientation. However, in the camera details panel, I’m not able to make the dimensions taller than wide. Any guidance is appreciated.


I was trying to figure this out myself. I asked the same question a while ago, but no reply. Still searching for the answer. My Original Question

I can’t find anything on this still… this is pretty lame.

Set the camera aspect ratio to 0.5625 (16/9)


My screen doesn’t even rotate when i turn my phone… doesn’t unreal do that automatically?

It’s forcing landscape mode on me and it won’t even rotate into portrait mode. Also, I’ve deleted every actor in the scene and my UMG still gets rendered and receives pressed and hover events, WITH NO ACTORS IN THE SCENE. I have no idea what is actually rendering my UMG Widget.

An easy (but pricey) solution would be an ‘event tick’ that checks if:

-getViewportSize | BreakVector | if X>Y then: use landscape UI, else, use portrait ui.
(optional) Set (in UIWidget) LandscapeBool (true), else, set as (False)

You can either set both ui’s independantly or have it (a single UI) rearrange itself based on a condition set by the action above.

Hope this wrks :wink:

1 Like

Under Project Settings, did you go to both Android & iOS settings where you can set the project to support Portrait Mode?

You can constrain aspect ratio to 0.5625 in your camera settings and this seems to work fine for some projects.

In my case doing the above would stop all my paper2D sprites from moving so I had to us the option above for desktop and for mobile I did the following:
Leave constrain aspect ratio “off” in your camera settings and in project settings go to Android > Maximum aspect ratio and set that to 0.5625.

Hope it helps

1 Like

Thank you so much! :+1: :+1: :+1: