How do I set a launch image for a Daydream Build?

I have no idea how to set a launch image for a daydream build. I tried a trick I saw previously on answerhub where you load a blank level first, load a splash image, and then load the level you want a player to start in, but it still takes awhile to get to the splash image. I assume what I want to do is set some sort of launch image like what you see in project settings, but the launch image setting in project settings does not appear to do anything. Any ideas?

Yes you can set it in the DefaultEngine.ini file in your projects Config folder so it shows up really quickly as per:
https://developers.google.com/vr/unreal/daydream-in-unreal#setup_a_daydream_splash_screen_for_your_application

Here’s what I set for my Daydream project:

[Daydream.Splash.Settings]
TexturePath=/Game/Textures/loadingScreen_daydream.loadingScreen_daydream
TextureUVOffset=(X=0.0, Y=0.0)
TextureUVSize=(X=1.0, Y=1.0)

and it is working in 4.15

in 4.16 I think it is slightly different. First you have to make sure that texture is referenced somewhere in your project and the path is changed to:

TexturePath=/Game/Textures/loadingScreen_daydream

Reason due to more agressive stripping of unused assets during cooking to reduce apk size, as per: GearVR loading Splash screen no longer working in 4.16P1 - Platform & Builds - Unreal Engine Forums

PS: the launch image setting in the project settings is for non-vr android builds only :wink:

Thank you. You’re awesome! I’ll try this.

I am sorry, I’m a little confused. There is no game folder in the project folders. Do I make this within the content folder? Game/Textures ? Also, the extension is strange. Does my extension have to be .loadingScreen_daydream or UnrealSplash as in the google docs? Can it just be png?

yeah I agree it’s strange but it is really as is.

The “game” folder signifies it’s the game content folder.

So my image is placed in:

Content/Textures

And the extension is the same as the asset name - yes it is strange but is needed in 4.15 at least. (This might be fixed in 4.16 though where for gearvr at least you don’t need to specify this strange extension anymore.)

Aussie you’re the best! I got it to work after I followed the instructions in your link about getting the launch image to work on Gear VR: GearVR loading Splash screen no longer working in 4.16P1 - Platform & Builds - Unreal Engine Forums . I had to drop the file extension and also cook the texture.

Are we the only two people on the planet finishing a UE4-based smartphone vr app?

Thanks again. I really appreciate it!

No problems! Don’t forget to accept the answer :wink:

I’m guessing there must be more UE4 daydream devs out there but they must not be checking the answerhub?

Oh there are other Unreal Daydream devs other there…

Sorry to revive this thread, but I’m having trouble getting a Daydream Splash Screen on Unreal 14.7.

I’ve been combing through threads related to this the past few days, about GearVR as well (as I needed that version as well), and only got one of the two platforms working (would not have even gotten there without the great help form everyone here).

I got the GearVR to work, but none of those solutions worked for me.
The only way I got it to work was to set it in the OculusVR Plugin.
I noticed that the section that gets added to the DefaultEngine.ini is totally different than what has been posted here and the related threads. For starters, the name of the header is even completely different:
It changed to [/Script/OculusHMD.OculusHMDRuntimeSettings]

And that is where I’m at with Daydream. Daydream does not have a specific plugin in like GearVR has, so I don’t have a place to assign it to that would add the correct format to the DefaultEngine ini. The official sites (and these threads) are all listing what I assume to be an outdated ini format. My fear is the Daydream one changed too, but nowhere has the updated setup.

Here’s what I’ve tried so far, and no combination has worked:

  • Using block of script for the ini from this thread with no change
  • Using block of script for the ini from this thread with the change to get rid of the .whatever as suggested in the follow up post for 4.16
  • Added the directory of my splash screen to the “Additional Directories to cook”
  • Added Daydream specific blueprint to set a splash screen in the following places:
  • In my player pawn
  • In my first level
  • In a blank/empty first level, and then loads into my real first level like the suggestion in a related post

Unless I’m forgetting something very easy in my setup, or have the order of the splash screen blueprint setup wrong/backwards?

Hey ErikWack - sorry for the late reply - I’m currently having the same problem updating my project to the new version of the engine (4.17+). We might need to ask google via the issues reporter of their branch of the engine here:
https://github.com/googlevr-unreal/UnrealEngine/issues
Able to ask?

That was a dead link for me…

At any rate, I somehow got this to work.
The format for the DefaultEngine.ini IS correct. 4.17 didn’t change that thankfully.
If I had my device connected to my PC via the Android Device Monitor (monitor.exe), while running as Development I could see the logs telling me that I had a valid texture specified instead of the default empty string. I knew it was working in some form though because the initial load and every level transition sent out a debug of “Splash Texture load successful!”
But even with seeing this, for a good while, I still saw nothing. I tried changing all of the variable (distance, scale, etc), thinking it was jsut in the wrong spot, but no change.

Turns out I had to turn off Multi-View & Multi-View Direct. Then it worked.
Oddly though, I turned Multi-View back on, and it still worked. ??? I have no clue what exactly is going on here, but in some ways it makes sense that multi-view could interfere with rendering the Splash screen.

I wish the GoogleVR plugin had a setup like the Oculus one does, where you can simply specify this in the editor. Would make setup a bit easier.

However, now I’m having the issue where after updating to Android 8.0 (is that Oreo?), it crashes on launch 100% of the time. So, I see the Splash screen, and then it crashes.
Basically this issue:

I tried what was suggested there, but now I can’t even get my project to successfully build anymore.
I keep getting this at the very end, during the final package preparation:
D:\NVPACK\android-sdk-windows\tools\ant\build.xml:573: …/support-v4-25.0.0 resolve to a path with no project.properties file for project Y:\JavaLibs\permission_library

I’ve updated the SDK’s, and still busted. This whole week has been very frustrating…

Hey Eric I don’t have Oreo yet so unfortunately cannot help there yet but after upgrading my project I still can’t get the loading screen to show :frowning: Able to show your ini settings for it?

This is what I have in my DefautEngine.ini

[Daydream.Splash.Settings]
TexturePath=/Game/UI/SplashScreens/Daydream/T_SplashScreen-Temp
TextureUVOffset=(X=0.0, Y=0.0)
TextureUVSize=(X=1.0, Y=1.0)
RenderDistanceInMeter=2.0

As said above, when hooked up to a PC the logs told me that it was loading it correctly. I had to turn off Mobile Multi-View to actually see it though.
For my project, RenderDistanceInMeter of 2.0 was far enough away to see it without it being super close (if I can ever get my project running again, I may try just a bit farther away).

Hopefully I can get my project building again so I can confirm the Splash Screen still works…

It turns out it is a 4.18 issue.
The Google dev offered a fix here:
https://github.com/googlevr-unreal/UnrealEngine/issues/23
which I can confirm works

Thanks for the response. I did get my Daydream Splash Screen working.
I am using 4.17.2. I didn’t go into github. I used the solution posted in the other thread:

I am just on the cusp of submitting my project (both to Google Play and Oculus/GearVR), so I can’t wait for 4.18. Besides, who knows what other issues it may introduce? I feel like my project is a Jenga tower with several blocks removed (the weird issues and hacks/loopholes to fix them), and somehow it’s still standing. Don’t feel like pulling out another bock. :slight_smile:

I know how you feel :smiley: 4.18 does introduce other issues :frowning: you should know S8 daydream crashes on 4.17 though :frowning: (which is why I’m upgrading to 4.18 in the first place)