How do i rotate my player in top down view without moving camera?

My issue is in my top down view i want to use the right stick on joystick to set the direction in which the player is looking. In my controller blueprint i was taking the inputs from stick creating a look rotation and setting the controller rotation. The problem with that is that the camera moves with the rotations. I guess it kind of makes sense since the camera is on a spring connected to player but i am not sure how to go about fixing the issue. Is there a way to get a static camera and still have it locked onto the player? Any suggestions would help. Thanks!

Try this out.

Thanks for your answer but unfortunately it didn’t work. When i set actor rotation nothing was happening to my characters. So then I tried setting controller rotation which basically did what i said before moving the camera with the actor.

I do like your blue print better help reduced the number of nodes i was using. Is there possibly an checkbox or something i need to uncheck? Or maybe i have my character set up wrong.

Are you using one of the pre-configured projects?

I am using a blueprint similar to how the player character is set up in the 3rd Person tutorials: - YouTube

The project was built from scratch but follows that tutorial. The only real difference is that my character blend space is 2d so that i could animate walking sideways/backwards too.

Tonight i may try moving camera to the level blueprint to see if that helps. I believe removing the camera from player may achieve what i am looking for but not sure how helpful that will be in long run.

Hey Benchi,

The problem you are likely hitting is that if you are rotating the Actor (your Character) then you are actually rotating the Capsule component (root component) which your camera is attached to by default. Try changing your code to rotate your Skeletal Mesh component instead of the entire Actor.

-Steve

Awesome thanks for your help that did the trick. I ended up getting the player character then the mesh then setting the relative rotation. Seems to work just need a few tweaks.

May be you should first set a “Set view Target with Blend” link to a “EventBegin” so you start directly with a top down camera that never change. This camera has to be in the scene not in the component. Just an idea.

I assume you are using USpringArmComponent for your camera:

SpringArmComponent->bInheritRoll = false;
SpringArmComponent->bInheritYaw = false;
SpringArmComponent->bInheritPitch = false;

Should do it.