Download

How do I repeat Mixamo walk animations in UE4?

Hello,

Newbie here. I’m trying to create a longer walk cycle for a character set up in Mixamo. The animation goes for about about two steps then stops. When I try to extend it with another animation of the same clip, the character returns to the original spot instead of continuing on from where he ended. I’m stumped. Any ideas to point me in the right direction? I don’t like the walk in place ones, because the feet slip.

Thanks in advance,

-Mike

Sounds like you have root motion in your animations. You need to get animations without root motion OR you need to set ‘Enable Root Motion’ in the animation. In the latter case you will need to create a Root motion controller to drive your character. Doing that is more work and makes creating multiplayer game more difficult but has better looking animation if your using motion capture based high quality animations.

If you work with 3ds max, there would be this technique :

-Create character in Mixamo (just character, no animations yet) or by any other means
*If you create your character, let’s say with 3ds max and you just want to use Mixamo’s animations, create your mesh, import in Mixamo, skin and rig there, then do the following step >
-Import your character in 3ds max (Before importing, make sure your System Units are set to cm, as well as the Display Unit!!)
-Use Mixamo’s autoCAT script to replace the original skeleton with a CAT rig (you can get it for free on their website)
-Select your CAT rig’s Base node > Modify Panel > Click on Motion Extraction Node (this will create a root bone for you, which you will need in UE4)
-Now select the Pelvis and go > Hierarchy Panel > Link Info > Bone Hierarchy > Animation Mode > Enable Additive to Setup Pose
Almost done!
-Select the CATrig’s Neck bone > Modify Panel > Spine Setup > Spine Control > Select Keyframed (it will warn you of something, click OK)
Repeat with Spine1 bone
-Select the CATrig’s Spine1 bone > Modify Panel > Spine Setup > Spine Control > Select Keyframed (it will warn you of something, click OK)

Now you are ready to export back to Mixamo to apply animations, but you don’t export everything. At this point I would highly recommend organizing the scene by creating a few layers:
-Layer 1 - Mesh > Contains Mesh
-Layer 2 - Controls > Contains Feet Platforms and CAT’s Base Node (not the one you just extracted though, the base one really)
-Layer 3 - CAT > Contains the actual CAT rig, Including the created Root Node

-Hide Layer 2 - Controls
-Select everything else
-Export Selected to FBX

Now you can import that in Mixamo and Add Animations as you wish. Once done, you just need to Capture Animations in 3ds max and retarget them to your CAT. Mixamo provides a tutorial on YT that shows how to do that, but quickly :

-With your previous scene still open in 3ds max > Create a new layer and give it the name of the animation you’re about to import (ex: Idle)
-Make sure that layer is selected > Import > Import > Pick your file
-In the Import Options, under Include > File Content : Select ADD
This will import the animation in the selected layer. If your units were set properly, sizes should match between your character and the imported animation skeleton
-Deselect everything
-In the upper main toolbar go to Animation > CAT > Capture Animation
-For Source Object select the imported animation skeleton’s Pelvis
-For Target Rig select the CATrig’s Pelvis
-In Mapping section, press Load and find folder where you extracted the AutoCAT script > Choose the only file available (Mixamo_AutoCAT_MappingPresets.cam)
-Wait for the process, then press Capture

Voilà! You now have your animation imported as a CAT Layer. You can export it, modify it at your wish and then, to export to UE4, quickly :

-To export skeletal mesh : select mesh layer + CAT layer only (make sure your CAT Animation Mode is not toggled)
-To export animations : select only the CAT layer
Also when you export, make sure to convert dummies to bones!

This might seem like a complicated process, but I’m absolutely beginner in Unreal Engine and this is the only method that works for me so far! There might be easier techniques, but at the same time I like having the flexibility to modify my animations at will using CAT!

Hope this helps!

I found the actual solution:
When you download the animations, you need to set them to stay in place. It’s as easy as 1 2 3.
Select the animation pack you wish to use.
Click “Customize Pack”
Checkmark “In-place”
Now, below that, click each and every other animation and check mark “In-place”
Kinda tedious, but works perfect.

I could find “in place” when selected a single animation but didnt see any of that or “Customize Pack” in a pack animation.
Could you tell me where exactly the “Customize Pack”?

This is an old thread, but for anyone wondering - once mesh is rigged in Mixamo, you check this box on right side of screen: