How do I remove a map from World Composition?

After updating to 4.3 and playing around with the wonderful World Composition tool, I noticed the “Starter map” with examples from Epic was loading along with my other maps, as well as some other maps I’d like to keep separate from the rest of the game world.

How do I remove/prevent these from being included in the infinite world?


World composition treats all maps as a streaming levels if they are in the same folder or sub-folders as your persistent map. So to isolate your world composition you should create a separate folder and place your persistent and streaming levels there.
Here is documentation

Ah, that did it! Thanks. I have another problem now - the levels are not staying where I place them in the composition - as soon as I hit play, they’re shifted away from the origin, leaving me floating in nothing. This happens even if I disable “Streaming Distance” in the layer settings to keep it always loaded.

Disabling streaming distance does not make them automatically loaded. It’s just a flag for a streaming system, that you don’t want to use distance based streaming and will implement custom streaming rules. Fro example you can use GetStreamingLevel BP node to get access to those levels and make sure that they are loaded and visible. Set ShouldBeLoaded and ShouldBeVisible properties to true.

I set the values in the level blueprint and the world does shift now. However, it sends my character speeding away in the opposite direction from the level - it doesn’t appear to be loaded in the levels overview either.

I tried using a “Load Streaming Level” node as well, but it produced the same result.

Do you have a PlayerStart actor in the persistent level?
And make sure that in Play menu you have chosen Spawn player at : Default Player Start.

I have “Default Player Start” as my spawn position, and the PlayerStart produces the same result in both the persistent and streaming level. I gave simulating the game a shot, but even there the level doesn’t load.

Solved it - I had forgotten to untick “Use Dedicated Server” inside the editor. Disabling that made everything run like a dream.