How do I prevent my character/camera from rotating on a rotating platform?

My game is a side scroller. So I need to prevent this from happening. Any help would be much appreciated.

Try to disabling the inherited yaw from the spring arm when on the platform (and enable it again when off):


I tried it. The camera is good and stays in place but the character rotates still like a paper. Is there a way to prevent the character mesh from rotating on the yaw as well? Thanks!

Character Movement Component > Ignore Base Rotation (check)

And no need to disable inherited yaw.

Sweet! Sorry for slow response. Busy during weekends. I’ll give it a try sometime later today. =D Thanks!

It worked! Thank you very much!