How do I point Unreal to the Perforce folder without creating a new project?

Setting up Perforce, I’ve successfully connected via P4Admin and P4V. I initially specified my Unreal folder in MyDocs as the Perforce workspace but it was having issues. I then created a new folder off my SSD for the Perforce connection. From there, I created a new Unreal Project and saved it in that location and was successful in synching those files to Perforce. The issue comes when I have other users connect; they’re able to connect and download the Unreal Project files I uploaded, but, when they open the .uproject file that launches unreal and attempt to connect to Perforce via the ‘Connect to Source Control’ option in the content browser, no workspace is available for them to choose, Is this a server side or client side workspace it is referring to?


The Perforce workspace is what maps the server-side depot files into a directory tree on your local machine.
There are a few reasons why workspaces may not be available to choose from the login dialog’s dropdown:

  • The workspace does not map to the projects root directory.
  • The workspace is not set up to be used with the clients host machine.

There are other potential issues too, related to how you have set up your source control server:

  • Do you have a locally-hosted server or is it remote, perhaps hosted by an external provider, like Assembla?
  • Is your server SSL or stream-enabled (neither of these features are supported by the current version, 4.0).

Finally, taking a look at your logs (stored in /Saved/Logs) can reveal potential problems with Perforce connections. If you continue to get issues please post a log from a connection attempt here and I’ll try to help.

Regarding the last two points, the server is hosted via Digital Ocean and is not in the streamsDepot but in the normal depot.

When I have users create a perforce workspace client-side, do they have to name it the same way I did when it was setup?

Regarding the first two points, could you provide what settings I should specify for perforce on a linux server to fix those? Does the workspace have to be in the same location for all other PC’s (for example C:\UnrealProject)?

Can you post a log so we can verify whether this is actually an issue with workspace mappings first?

Please start up the editor, bring up the source control login dialog & click the workspaces drop-down, then shut the editor down & post the resulting log (located as above) here.

Tom, thank you for your persistence in helping me gauge this issue. I’m not entirely sure what fixed it, but when I went through the P4V install 1 on 1 with my users, it worked perfectly. I believe the issue may have somehow been based around the fact that they never setup a custom location or workspace name, so default values were applied. This worked fine through P4V and getting our depot, but it never would populate the dropdown in UE4. After deleting that workspace and creating a new with a custom name, all works perfectly. Thank you sir.