How do i mute certain sounds in a certain area (in a room) ?

After reading the documentation, the only way i see it done is using another sound (0 volume) with volume ducking as described here
What am i missing here? there must be a more direct way, right?

Is this multiplayer?

no, just an architectural visualisation walkthrough, with ambient sound

i dont want ambiental city noise to be audible inside my building

If you’re using bp I guess you could use play sound at location node and use an overlap event to turn the sound down or off (Or maybe have two sound assets, one very quiet that you switch to after overlap event)? If you’re using C++ you could use an overlap event to change the sound’s location.

I was trying to find a picture of a bp using that node- this one shows a play sound attached node;

You can also use a switch on that. I’ve used one here (I think there’s 4 sound assets in it and they switch between them based on an int variable);

If you look further up that audio documentation page, you’ll see a section on sound mixes. The volume ducking section discusses passive mixes but you can also activate these at will, pushing and popping them as you enter and exit volumes. I’m not sure of the details off the top of my head but I think there are some options for affecting sounds on ambient sound volumes too.

Edit: I was thinking of reverb volumes, these can affect the volumes of sounds based on whether they are positioned in or outside of the volume, not necessarily by what their class is. I’d stick with pushing and popping sound mixes.

Since i haven’t tried blueprints yet i was looking for a solution outside of it, and i finally figured it out.
For future reference, here’s what worked for me:


Created sound class “outside”, assigned outside sounds to it under the sound’s “sound class override” dropdown; created class “inside”, assigned inside sounds to it. Created sound mix “mute_ambient” with “0” value under the volume adjuster- this muted outside noise completly. In the sound mix, under sound classes, i selected “Outside”. In the “Inside” sound class, i selected “mute_ambient” from the “passive sound mix modifiers” dropdown. Done!



I assigned sound cues to sound classes, and ticked the “apply ambient volume” box inside those sound classes. Created a reverb volume and lowered the external volume parameter under “ambient zone settings”. The other parameters control the transition effect as described here.

I tried B without sound classes but it didnt work.

Thanks a lot guys!