How do I match editor and build performance?


I’m having an issue where my game is running fine in the editor but terrible in the build. I’ve disabled framerate smoothing and locking. I’ve also disabled monitor editor performance from the scalability settings in engine. I’m truly baffled. I’m also learning as I go about optimisation but its difficult to optimise when it actually runs well in the editor anyway. Does anyone have an ideas what might be going on here and what I can try to resolve it?

I seem to have mostly resolved this issue. It’s not a perfect match but it’s much closer now. I’m using toggleable lights in my scene. I didn’t realise that a dynamic light with an intensity of 0 still calculates shadow information. Adding disable shadow casting as gotten the build to a mostly smooth 60fps. It doesn’t explain really why this behaviour wasn’t happening in the editor but a win is a win so i’ll take it.

Should probably report that as a bug :stuck_out_tongue: