How do I make my sphere tracker track more often?

I’m using an animation notifier state to create a sphere track from channel. I have the nodes for the sphere track in the “received notify tick” section, but I have only ever gotten it to track like 2-4 times. I was wondering if there was a way to increase the amount of times that it will track.

what is a sphere tracker? O_o

That aside, possible solutions include changing the tick group or changing the tick time for the blueprint.
I’m assuming this is within the context of an anim graph because of the notify. If thats the case then maybe a different tick group is the way you want to go.

If you explain what you are doing i may be able to give you a better answer…

I meant to type sphere trace, I don’t really know how I messed that up.

Makes more sense.

How are you using the trace?
Meaning - is it just set to trace when the Notify starts?

The way i have it set up is: “Received Notify Tick > SphereTraceByChannel > ApplyDamage > Return”

So, notifies are set up to not be accurate.
they fire whenever they can, not always on time. Depending on cpu and gpu load.
Why are you using a notify for this?

instead, run the trace on tick.
and enable it/disable it by using the same transition rule that gets you to the animation.
This way you are essentially always checking for impact during the animation without having to relay on the tick event call at all.

Sorry, I’m still pretty new to unreal engine, and don’t think I understand completely what you are trying to say, is there any chance you could show me an example of how that would be set up.

Not really, it’s dependent on what you are doing.

Get the sphere trace running on the tick event for the character.
Add a branch in front that let’s you run the trace when it is true.

whatever way you are triggering the animation to start playing is the boolean you will want to use to start the trace.

Okay, I think i understand, thanks for the help

Make sure the notify tick type is set to Branching Point - much more accurate than the default of Queued.…ies/index.html