How do I make my enemies turn to their aim?


History is: I’ve renamed my “TopDownBP”-Folder and suddenly my project went completely black. So I renamed this Folder again to “TopDownBP” and almost everything went to it’s place again, except the enemy-actor’s mesh and animation BP, which I reassigned.

Now everything is like it was before, but my enemies don’t turn to my character anymore as they’re chasing it (see gif). I’m sure I’m missing a simple checkbox oder something alike.

You have any idea?


You can set the AI controller’s focus to the actor you want it to look at.

Hi Nebko, here are a couple of things you could try out to see if any of the default settings were accidentally changed:

Check if ‘Use Controller Rotation Yaw’ is ticked in the properties of your AI Character. If not, tick this option and see if things are working out.

If that’s ticked, go to it’s Character Movement component’s properties and tick the ‘Orient Rotation to Movement’.

Thanks for your replies! The checkbox ‘Orient Rotation to Movement’ wasn’t checked, now everything’s working! :slight_smile:
The “SetFocus”-Node did the trick as well, but the checkbox solution is quite simpler.