Download

How do I make interior spaces with no windows, dark?

Below is a pic of an interior space with no windows. It has light. I have never been able to make these spaces dark so I can play with subdued lighting in an interior space. What do I have to turn off or change do get theses spaces dark? Thanks.

Disable skylighting or bake the lighting.

Turning off the skylight in the world outliner makes no difference.

I have a medieval village and as you look into the blacksmiths through it’s big open door it looks unnaturally light in there. All my lights are movable for extra quality as this is for a movie not a game. I have medieval buildings with virtually no windows that need interiors that have shafts of light lit catching atmospheric dust and none of that is possible while this problem exists.

You’re seeing the effects of eye adaptation, I believe. If you want to turn it off entirely, you can go to Settings -> Project Settings / Engine / Rendering. In the Default Postprocessing Settings section, turn off Auto Exposure.

If you just want to dial it back a bit, drop a Post Process Volume into that area, and go to the Auto Exposure settings and change the Min Brightness and Max Brightness values to be a closer together than the defaults. If you set both values to the same number, then it’s effectively turning eye adaptation off.

Thanks Kirk, I’ll try dropping a post process volume around that area and dial back eye adaption.