How do I lock the Editor to 30fps?

Hey there,

I am using a Geforce 470 GTX in the moment to develop using Unreal 4, the card is from 2010 but it still able to achieve quite decent framrates, however when doing this the card goes up to 100% usage and is very loud, what i always tend to do is limit the fps to 30 and reduce settings but i am not really sure how i would go about locking the editor to only use 30 fps?

I also do not want the card to die yet, will need to keep it for some months

Oh it wont die. I’m using the engine on a GTX 460 for several months now and it’s still alive. One thing you can do though turn real time off when you dont need it.

Good to know :D, i just hate it when the card goes super loud, isn’t it possible to regulate fan speed and stuff from a external application?

You might find an application like that but i wouldn’t suggest lowering the fan speed. Mine gets loud too but i dont mind it. I’m cool as long as my gfx is cool. :slight_smile:

comment deleted.

It’s definetly possible, however I don’t recommend it as change fan speed by force can damage your card. If you still interested, google app SpeedFan or similar, but be careful.

but i am not really sure how i would go about locking the editor to only use 30 fps?

On the top right corner of the main Editor window, there is a text box that says “Enter console command here”. Type “t.MaxFPS 30” to lock the Editor FPS to 30.

2 Likes

@highflex: glad it worked! Please don’t forget to mark my answer as accepted! Thanks

Thank you! that works :slight_smile:

done :), getting used to this site, much better than forums for questions :slight_smile:

everything is now running fine, back digging into ue4 :smiley:

Would be great if this was exposed to the GUI!

if you want the editor to open with the default set to
MaxFPS = 30:

open:
config/ConsoleVariables.ini

//find: 
[Startup]
 
//under it write:
t.MaxFPS=30

Note: In newer versions of the editor, even the console is not exposed in the GUI anymore. See this answer for more information.

that worked for me thanks! my card was screaming (coil whine) rendering at 120 fps. Now its a smooth 60fps. Not sure why Epic don’t cap fps by default to 60.

Is there a way to change the max FPS for Android mobile?

It seems to be capped at 60 fps.

I’m currently doing the following which works for desktop but not mobile.

https://github.com/EpicGames/UnrealEngine/blob/master/Engine/Source/Runtime/Engine/Classes/Engine/Engine.h#L1781

/** Get max fps. */
virtual float GetMaxFPS() const;

/** Set max fps. Overrides console variable. */
virtual void SetMaxFPS(const float MaxFPS);

t.MaxFPS=30 was best option before, but it didn’t worked for me in UE 4.17.1
For future readers: You can always use ‘Nvidia Profile Inspector’ to limit editor FPS.

Thanks man! My laptop was heating up whenever I was using UE4. Now I limited the FPS to 30 and it works cool now.