How do I include the leap-motion-plugin into an existing project?

I’m working on a project in UE4.7.5 and I want to use Leap Motion in the project.
I downloaded the plugin and copied the LeapMotionController-folder into the plugin-folder of my existing project.
I could now enable the plugin in the projectsettings. UE4 wanted to restart to use the plugin so I tried it.
But then the message
“The following modules are missing or built with a different engine version:
Would you like to rebuild them now?” appeared.
So I pressed Yes.
And now the error-message “MyProject could not be compiled. Try rebuilding from source manually” appeared.
I don’t know what to do now to make Leap Motion work.
I can’t find the missing module anywhere on my computer.
And I don’t know how to rebuild from the source manually.

I solved the problem.
If someone wants to know how just ask.

Hello Plasmaschnee I am suffering from this problem, can you help me?

hey ! i found myself in the same situation, could you explain how you fixed that ? thank you :slight_smile:

I followed these instructions until after the download from Github.
Then I used the setup.bat in the directory. After that there was a UE4.sln in the directory which I used with Visual Studio.
After it built the whole Unreal Engine new in Visual Studio I launched it clicking on “Local Windows-Debugger” and it started Unreal Engine 4.
Now it let me choose the project I wanted to open with this version of UE4.
I chose my project and it told me, that I needed to convert it to the new UE4-Version. There also is the option to open a copy of the project so that you have one version in 4.7 and the other in the version with the plugin.
After the project was open I continued to follow the instructions “Enable the plugin” from the same page as before.
To find the “Leap Motion Controller” I followed this guide:
I hope that helps. If it is still not working tell me exactly where it didn’t work and I will try to help.