How do i import static mesh with textures from blender?

hello !

how can i import my stuff from blender with textures into UE4 ?

i made a house in blender with 5 textures on it and i now want to import it in the game engine …

what works : i can import the “naked” house (it has the correct size)

what not works : all textures are gone …

i exported it as .fbx …

i tried everything i could find with google and i watched every video i could find on youtube … played around with the export settings

but i cant get it to work

thank you

most likely that your textures are jpg which UE4 doesn’t import, make sure the textures are bmp/png/tga others are supported but i can’t rremember off the top of my head.

Also when you export the FBX, in the FBX Options dialog make sure you have the “Embed Media” option checked, or it will not copy the textures.

I hope this is what the option is called in Blender, I use 3ds Max, so if you can’t find a checkbox named like that, search for one relating to materials/textures and turn it on.

I’m using jpg’s for my walls fine, and creating materials with them, but then again I’m not importing them with a model, is there an exception when used for importing a model?

thanks for the answers …

its .png …

and i am playing with the export settings the whole day …

i dont understandt why everything is so complicated with this engine …

i mean … this is such a basic thing … create something … export it and import it into UE4 … but noooo

i spent my whole day trying to export something with a texture into this engine …

even if i only take a cube … put a texture on in … its not working

witch version of blender are you using? and witch exporter?

newest blender and .fbx exporter

Not sure what’s your issue but it should simply work. Just make sure to actually add the textures to your material in blender and check “Import Textures” on UE4 imort.

Took me longer to do this pic than exporting and importing the model with textures:
c0202087983a1368693bdb85dae6279ca350e6f5.jpeg

You can also import the material although it probably won’t assign all textures to the right material slots, except diffuse and normal.

i think i am doing something wrong with blender … i am lost somewhere between words like uv-unwrap,materiel,texture,image,faces, and what not …

so to learn all that i started very simple… i downloaded a .jpp from cgtextures and “put” it on the default cube … by “put” i mean : i watched all youtube videos i could find on youtube and then did what they did and tried to export that …

for example : i watched what he did http://www.youtube.com/watch?v=cUkNOF8eORA … i have the same result …when i use render mode everything is fine…and then tried to export it …

if i export something - i only get an .fbx file … nothing more … i tired to play around with the settings … set it to .png … changed the folder and so on …changed fbx 7.4 to 6.1 and so on …

I personally always do it like that:

  1. create the mesh + uv mapping (e.g just put a texture onto it -> edit mode -> press U -> unwrap)
  2. now export your mesh -> so the fbx file
  3. now export the texture and import it into the UE4 -> png, bmp, tga
  4. right click onto the texture in the UE4 -> create material
  5. drag and drop/assign the material to the mesh

Now you should have a mesh with materials in your game. Thats a rough overview of the whole import/export process :slight_smile:

you can laugh about me now … but i cant even reproduce that ^^

what i did :

i opened blender.

under “metric” i changed “scale” to 0.01 (so that1meter in blender is 1 meter in UE4)

i rightclickted the default cube and changed the size to 10meter * 10meter * 10meter

then i pressed “a” for select all … then control+a to set the scale from 100 to 1

i changed to “composite” view … pressed “a” to select the whole cube … then “mesh”-> “uv unwrap” → “unwrap”

then i eported it and imported it into UE4 … works fine … cube has the correct size …

if i try to put a material on it and press “build” -> ERROR (uv overlapping somewhat and the material is scaled to much)


then i tried to do exactly what you said but :

i) the default cube is tiny in UR4

ii) 3.how do i export the texture ?

iii) when i have to drag and drop the texture/material in UE4 on the mesh - how does it work with more material ? lets say i build a house in blender and i have textures for a door,window,wall …when i export this mesh then import it into UE4 i have one object… and when i put a material on it it will cover the whole object

Ah, you get an overlapping uv error ^^

You can solve that error with a 2nd uv channel: Unreal Engine 4 Tutorial: 2nd UV Channel (english) - YouTube

i: yeah, you can always scale it in the UE4, but just scale it up in blender
ii: when you have the texture on your desktop/folder then just import it from there, but sometime blender artists store their textures in blender, but I think that wont be the case in your situation ^^
iii: Here is a tutorial how you can assign more then one texture/material: https://www.youtube.com/watch?v=bQ9zSmuh8OI. WHen you double click the mesh you should see material slots

ii) that does not work : i create a cube … select 2 different faces and assign 2 different textures … if i now import the .fbx and the textures - the textures dont show up on the cube … i can see the textures under “material” slot0 and slot1 but not on the ingame cube

another problem is that if i try to apply a default materiel - it covers the whole cube and it is scaled 100x larger … i think this has something to do with the 0.01 from blender …but if i dont to that in blender then my cube is too tiny in UE4

iii) works fine if i only use colors … doesnt work with textures

:wink: When I’m back from Brighton (tomorrow) I will record a video for you. But you could also add me at Skype: nasph96

that would be supercool thx !

would be cool if you could also explain how i can prevent the material from scaling …

for example if make the default cube in blender a little bigger, import it into UE4 and try to put a metarial on it it always scales up so that it looks like complete **** …

i tried to change the settings in blender to 0.01 but that does not work … i tried to “set back” the scale by pressing ctrl+a after i made the cube bigger so that the scale is back to 1.0 but nothing works

There is an easy solution for that directly in the UE4 ^^ -> just add a texture coordinate in the material and scale the texture down

i simply made a cube in blender … exported it … put some “default” material from UE4 on it and it is scaled … (for a reason i dont understand …like in the image above)

when i doubleclick the material i get something like this :

and i have no idea what to do :smiley:

when i change something - would that mean that the material would be changed in general ? so i have to make 20 different materials for 20 cubes out of that one material ?

when i started to learn UE4 i thought : maybe in 6-12 months i would be able to create a very small level or something … not even a game … but i now think that this is completly unrealistic … i mean i am trying to get this simple task done for a week now … and i really mean : a weak … i am sitting here the whole day … read/watch tutorials and play around with the stuff and i dont get such simple things done

if there wouldnt be people like you who are trying to help i already would have thrown my pc out of the window because this all make me soo aggressive :smiley:

In a material you can change the appearance of your texture (effects, tiling,…).Therefore you use nodes which have different effects. Mostly you create a Parent Material (so just a normal material with paramatere nodes) and after that you can create material instance constants (right click onto your parent material → create material instance…). Now you apply the materials onto your meshes → e.g 1 MIC to a “red brick cube” another MIC to the “stone brick cube”…

Now in the MIC you can change the texture and some other effects -> but of course just when you have used parameters!!!
8af6463c663703823e1090faf544eb93f29e7ef1.jpeg thats the part behind the bump offset node

I would also recommend you to take a look at a UV mapping tutorial. :wink:

As I said, add me in Skype, then I can explain you some stuff (nasph96 - Philipp) :slight_smile:

I’m having the same problem, using Blender 2.76b and UE4. What I found is that if you use Cycles render in Blender, exported files will NOT contain materials / textures. This can be verified by trying to import the same file you exported back into Blender again; the same will happen, materials and textures are gone. If you instead use Blender Render, exported fbx files will contain materials, and load just fine into UE4. I guess this has todo with the node system that you can use to describe materials with Cycles render (?).