How do I get Steam Audio to run on my Mac?


I’m new to UE and wanted to have a look at Steam Audio. I’m following the manual (steamaudio_manual_unreal_2.0-beta.3.pdf), but I can’t perform the tasks below:

Enabling Audio Mixer Functionality

  1. In the Epic Games Launcher, click Library.
  2. Click the down arrow next to the Unreal Engine version you want to use
    (4.16 or later), and click Create
    Shortcut. You can use any other method
    to create a shortcut to the editor.

There is no “Create Shortcut” item int the dropdown when I click the down arrow. I don’t know what other methods there are, all my searching around for “shortcut” in an UE context only yielded results to keyboard shortcuts.

I tried running the editor from the command line with the -audiomixer flag instead with the following command as super user:

open /Users/Shared/Epic\ Games/UE_4.17/Engine/Binaries/Mac/ --args "/Users/[user]/Documents/Unreal\ Projects/test/test.uproject" -audiomixer

It opens the project fine (just a blank blueprint), and I’ve already selected the Steam Audio Plugin as it is told in the manual but there is no “Spatialization Algorith” dropdown field in my Attenuation Override properties. Am I mising something?

It’s currently only supported on Windows in 4.17 as the Mac backend was just implemented for 4.17. We have plans for supporting all the platforms Steam Audio supports in near future releases.