How do I get rid of these warnings (UE5.0.1) (Project was converted from 4.27.2)


LogRenderer: Warning: Deprectaed CVar r.BasePassOutputsVelocity is set to 0. Remove and use r.VelocityOutputPass instead.

LogRenderer: Warning: Deprectaed CVar r.VertexDeformationOutputsVelocity is set to 0. Remove and use r.Velocity.EnableVertexDeformation instead.

It is only a guess but perhaps these variables are present in your DefaultEngine.ini and should be replaced by the new variables.


No sir, I did a text search for the entire project directory the only hits I got were log entries from the console spamming the error during a build. I triple checked the .ini’s and nothing to be found.

I didn’t research both, but had the warning for BasePassOutputsVelocity. It was in the DefaultEngine.ini in my project directory (as mentioned above), but also appears in the Config directory of the base project (which appears to be just a link in my IDE so actually the same file). The rvalue they said to use is in Cooker section of Project Settings (VelocityOutputPass). Mine was already set and I still got the warning. I was going to try and delete it out of the DefaultEngine.ini and run the build again.

The way I fixed this was to remove the defaultengine.ini out of my project and let the engine recreate it after starting the project from the launcher.

Then I had to setup the settings that I changed before including the game mode, and rendering settings. It also recompiled all the shaders before the changes and after the changes.

The error says how to fix the issue, mostly.

As others said before me, check your DefaultEngine.ini file [PROJECTDIR\Config\DefaultEngine.ini]

For a 1 to 1 fix, remove both r.BasePassOutputsVelocity and VertexDeformationOutputsVelocity
and replace them with r.VelocityOutputPass=1 and r.Velocity.EnableVertexDeformation=1

The documentation says to default VelocityOutputPass to 0, unless you encounter issues.

Documentation: Unreal Engine 5.0 Release Notes | Unreal Engine 5.0 Documentation
“Deprecated: Added a new console variable r.VelocityOutputPass to replace r.BasePassOutputsVelocity. If you were using r.BasePassOutputsVelocity=0, the equivalent setting is r.VelocityOutputPass=1. In both cases, it is recommended to use a r.VelocityOutputPass=0 and only revert to the old behavior if you encounter issues.”

Don’t know if this is a 1:1 solution since mine were set to false but you said to set them to 1. When I changed them but kept the false setting, my project opened just fine.

When I put 1 for each value, my project had to recompile all its shaders again and it took a very long time…