How do I get rid of incompatible version warning?

Dear all,

I have been using 4.5 branch from GitHub while creating some content. Because it is easier to coordinate with the team, we switched to 4.6 from luncher. After fixing initial API changes, everything runs smoothly but I am receiving (annoying) warnings every time I lunch or package the project:

Asset ‘…/…/…/…/…/…/Arenaz/Arenaz/Content/Effects/Stuns/BP_Stun.uasset’ has been saved with empty engine version. The asset will be loaded but may be incompatible.

This happens for all assets. Is there anyway to apply version to blueprint?

Best regards,

1 Like

Hey ziga.osolin-

You should be able to right click the .uproject file inside the project folder and select the option to “Switch Engine Version” to the version you want to use (in this case 4.6). If it is a code project or has any code added to it, you’ll then need to right click the .uproject again and select the “Generate Visual Studios project files”. This should associate the project and its files to the version of the engine selected.


Doug Wilson

Sorry to reopen this issue this late but the solution you described does not work for me. The warning that the uasset files are saved without version remains. I have tried UE4Editor.exe -run=resavepackages -maxver=214 and it gets rid of some but not all warnings. All warnings still pop up when packaging.

Hey Ziga-

Are you still working in 4.6 or are you using 4.7.1 now? You could try verifying your engine version from the launcher by clicking the drop down arrow next to the version number and try launching the project again. Another option would be to remove the asset from the Content folder (simply move to the desktop or another folder) and open the project normally. Then you can import the asset back into the project.

Hi Doug,

I have been using the most recent stable version all the time, also updating to 4.7.1 did not change any of the import errors. From what I think I know is that some (100-200) of my 2000+ .uassets complain that they have been saved with empty engine version. The asset will be loaded but may be incompatible. I tried all you strategies: the engine is bound to version 4.7.1, I have recompiled and remade C++ part of the project several times, … Removing the asset and reimporting works, as well as (in most cases) opening the asset and changing
something about it, then saving. So the solution is just to resave the asset.

So if anyone has similiar issues, resave the assets in 4.7 and it should work (I think this did not work in 4.6). This issue arose by using 4.5 Git branch that saved the assets without version (I think). I am just wondering if there is a (command line) option to force resave all the assets to speed up my work, opening up 200 assets is tiresome.

Thanks for help

If you simply need to re-save the assets (and they are in the same project) you can use File->Save All to save everything in the current project (assets, blueprints, levels, etc.). If editing the asset prior to saving is needed the you will have to take the time to open and edit each, but can then do a Save All rather than saving individually.


Doug Wilson

Additionally, you can disable the warnings being shown (sometimes, indeed the warning may repop, at least in my case). You just need to add
to DefaultEngine.ini. Check Assets "saved with empty engine version" warning. - Feedback for Unreal Engine team - Unreal Engine Forums for discussion.

This workaround is true for UE5 as well. Thank you @ziga.osolin !