Download

how do i get my Projectile to ignore Owner ?

I’m fairly sure this was thing in the old days…
but when i spawn my projectile, id like to say : ignore the Owner
is this at all possible?

the closest i could find was : Ignore Actor When Moving(target=projectile sphere, Actor=Gun)
didnt seem to do anything

tried setting my projectile sphere to no collision and touch, then trying to do some clever logic with the End/Begin overlaps but it got messy (and didnt work) very quicky

Also try to add the projectile into the ignore list of the Spawner. So both entities must ignore each other

Someone revive this thread! This is exactly my problem!

You have to use the forward vector from the actor as to not spawn inside of it.

Watch this tutorial, it has the answer in detail.

https://www.youtube.com/watch?v=s56H-C0iFDw

When you spawn the projectile actor, send in self as an instigator. Then in the actual projectile blueprints, do a check if “other actor” is equal to “get instigator” if it is, then do nothing.

First post and it’s not a bad one. The problem with Instigator (AFAIK) is that it’s of type Pawn. Best to do what you’re suggesting with SpawnActor’s Owner parameter. Not sure why I didn’t think of it before but it works nicely.

For anyone who needs specifics: Pass in “reference to Self” to the “Owner” pin of “Spawn Actor From Class” when you spawn your projectile. The owner should be the weapon actor. Then in your “On Component Hit” event, first thing you do is a Branch that checks if “Other Actor” is NOT equivalent to the output of a “Get Owner” node. If true, then handle the collision. If false, then it collided with its own weapon so ignore it. (Should’ve just done screenshots, oh well)

For anybody who is looking at this now, just add ignore Actor when moving node in the begin play of the projectile, like this. Better than Adding a branch on the On Component Hit, it will work 100%.

2e596cfc204ec808198ba680c0b1fb57e5d5660e.png

2 Likes

Thank you for this post! I was very close and had the right idea, but didn’t think of placing it in begin play. I was trying upon the hit, which it’s obviously too late at that point since the collision was already registered.

Ignore actor worked perfectly. Projectile is set at begin play to ignore instigator. As soon as the projectile is spawned in the character BP i tell the character mesh to ignore it. My character capsule was already ignoring my projectile so I only had to tell the mesh to ignore it.

I prefer creating 2 new collision object types. One for Pawn Capsule and one for Projectile. Update the pawns capsule component to use the Pawn Capsule and Projectile uses projectile. Both ignore each other. Beyond that I ignore self on spawn.

Unless your pawn is moving extremely fast then the projectile should never collide with the skeletal mesh.