How do I fix level sequencer falling camera?

I’ve watched numerous tutorials and read a couple of forum posts and can’t seem work out what I’m doing wrong. The problem is that when I render a movie, a random camera is generated in the map and falls indifinitely (or untill it hits the ground). The entire captured movie is just a falling camera ignoring all keyframes which previews fine in the cinematic viewport.

I work a lot in After Effects etc so I get how to do the keyframing. Also my map has no character pawns, player starts or secondary cameras. Here’s my process.

  1. Create a level sequencer
  2. Place a camera in the world and pilot
  3. Set the view to cinematic view
  4. Open up sequence and drag camera in (+ lock camera to viewport (camera button))
  5. Set location keyframe at 0fps and move the camera forward adding another keyframe at 30fps
  6. Preview the working camera motion in the level sequence timeline > plays as expected
  7. Animation settings look good > Hit Render
  8. Renders video… (Captures a falling camera from a random location)

I’ve seen some old forum threads that seem to describe what appears to be the some problem, ignoring cameras placing in the map. The comments just mention that the level sequence was still very experimental at the time so I haven’t found any solutions yet.

Sounds like you might need a camera cut track. Take a look here:

If that’s not it, can you attach an image of the tracks you have so far?

Have you created the scene from scratch or using marketplace stuff. Whats happened to me so often is I bring stuff in from marketplace and theres some Level Blueprint in there that messes with Sequencer

When you hit export in Sequencer its like when you hit play so you can also check the gameplay mode in the project settings and see if that is messing with it

I really don’t understand why Sequencer isnt a What you see is what you get reality . There are so many weird little things that have happpened to me when you hit export that do not happen by just hitting play in the timeline . In one tutorial or livestream they mentioned for a brief second about writing some special gameplay mode for RoboRecall to shut off or only make certain things working when you use sequencer - boggles me why in no tutorial or livestream do they go into this at all . You also have to hit save in the timeline to make things like the filmback settings take hold

Thanks a lot, since adding this the scenes render out correctly.

It turns out I needed to add cut scenes although the name seems a bit counter intuitive since I only had the one camera.

Thanks for the input though as this is useful to know. I think there should be an overide button the forces the whatever is playing in the Cinematic timelime to render regadless of level blueprints, gamemodes, etc.

Seems like a heavy scene drops keyframes at the end. Will try to cut the clip in two.