How do I fix? Installer is stuck on a update loop

Everytime I try to install Epic Games Installer, it gets stuck on an “Verifying Update” loop, but if I were to click on the icon it would crash.

have the same issue and could’t find a fix.sent an email and no answer for 1 week now :frowning:
Case #1508091.

What are you trying to install it on? You may not have enough room on your drive.

No my mac 500 gigabyte and only thing on it is the launcher :slight_smile:
i only try it on my mac(i7 late 2013) because on laptop with windows 10 the performance is very awkward (i5 4 gen)
So after i instal the launcher(ver 7 - 40 migabytes ) it download an update (100 migabates) then the loop of checking for update begin. Removed it and delete the unreal folder from users download new copy install update 100 miga the the loop try this 4 times with the same result :confused:

yeah i have tons of space on my laptop, happens to me aswell

same with me

I have the same problem, don’t know how to fix it

I have the same problem in my macOS High Sierra .

I found a solution
1.Uninstall Epic Games Launcher and reinstall it
2.After you open the .dmg file, drag it onto your desktop
3. Make a new folder called “Epic Games Launcher” And make sure it’s spelled exactly that way
4. Right click on the original Epic games installer and click show package contents
5. Copy the contents and past it into the Epic Games Launcher folder that you just made
6. Delete the epic games launcher app and eject the .dmg file
7. Rename the Epic Games Launcher to “Epic Games”
8. Click on add and it should run normally


Thank you so much for this!!! It worked Beautifully

1 Like

Thanks a lot it really worked!