How do I enable simulate physics? It's greyed out

I’m starting out with Unreal and using the Flying Blueprint.

I am trying to enable the simulate physics, it seems to be greyed out and unselectable.

I read somewhere that collisions had to be set up, so I enter the static mesh options of the UFO and in the collisions drop down menu I select Add 26DOP Simplified Collision and click Save but still the simulate physics is greyed out and unselectable. I also went into the mesh options of the UFO and clicked on the big collisions button and checked simple collision and hit save, but none the less the simulate physics is still unselectable.

I am still not sure if the collision options I am choosing are being saved, because when I go into the static mesh options of the UFO the simple collisions is not checked…
So I don’t know what I’m doing wrong… :confused:

What you need is a Physics asset for your skeletal mesh (UFO) in order for the simulate physics to available.(Different than it’s collision object)

You can create one by right clicking the skeletal mesh asset in the content browser and go to Create / Physics Asset / Create and Assign. That should enable the simulate option within the character blueprint.

3 Likes

What if I have collision enabled and a working phat (Physics Asset) and the button is still greyed out? The simulation in phat works beautifully but not anywhere else. I am trying to simulate physics on a skeletal mesh component hair armature added on to the main actor. I’ve tried everything…

1 Like

did you ever find the solution to this?

Had the same issue. Open the skeletal mesh - and set the physics asset for it. Sometimes in the project, you have skeletal meshes and physics assets. and it IS a physics asset for this skeletal mesh - but it’s not set as being in use. Cant be done on blueprint level - only in the skeletal mesh asset details.

1 Like

What does one do, if this is a static mesh , in a bp, in my case for a BP created Rope ( cable component) ? NO matter what I do, I can’t find a way to un-grey physics > simulate physics , for the static mesh, that is the ‘seat’ at bottom of rope player will sit on for gameplay, etc.

People are funny, the man ask a solution for a STATIC mesh but everyone here just give him the solution for the skeletal mesh…

Just give StaticMeshComponent a static mesh, then you can enable simulate physics.