How do I enable HDR?

I’m using an LG G1 TV with HDR enabled in windows and in nvidia control panel. I’m not sure I’m enabling it correctly. High Dynamic Range Display Output | Unreal Engine Documentation

I’m using the console commands from link above.
r.AllowHDR 1
r.HDR.EnableHDROutput 1

I’m not sure what to set the output display to or the color gamut display in the console. When HDR is enabled I’m not sure it’s displaying right because it has far too much contrast.



Its a very difficult subject to respond to and most dont have an hdr display so that’s why not many would reply :wink:
Are you using the console commands manually instead of getting the game user settings through blueprint? Reason i ask because looking through the documentation it says:
“The Game User Settings controls will automatically clamp to the closest available match for the current output device and set all flags accordingly. Alternatively, you can use the following console variables to enable and change the available options for the HDR device and color gamut output needed.”
As im reading it seems when you use the console commands it is more of a manual input.
So you would need to manually set r.HDR.Display.OutputDevice and r.HDR.Display.ColorGamut.
I would suggest you try to do a blueprint setup as displayed in the documentation as it would automatically set certain flags and clamp to the closest available display match.
Hopefully this helps :slight_smile:

Thanks for the reply ese. I have been using the console commands because I couldn’t figure out how to make the blueprint listed. I re-create what’s there but is there anything else I need to create within that window? I haven’t used blueprints before. It looks like other stuff is connected to them.

I re-created the node setup and nothing is happening. What plugs into Get game user settings and what does enable console command plug into? How do I execute the blueprint?

If you are new to blueprints then i would suggest finding some beginner course from the unreal learn section. Learn How to Use Unreal Engine - A Powerful Real-Time 3D Creation Platform - Unreal Engine
It could plug into many things depending on how you want to enable it.
For example you could have a button in a settings menu, in that case you would have something like a “onclicked” node attached to the beginning of it so when the player clicks enable on hdr it would execute that blueprint code.
Or in your case if you want a quick test of it you can plug it into a “beginplay” node that executes once you begin playing.
There is also in the editor under edit->editor preferences a “enable editor support for hdr monitors” toggle. That would set the editor itself in hdr mode.

I used your last solution by ticking the ‘enable editor support for HDR’ option. How do I know it’s displaying in HDR now and correctly? Thanks

You should be able to see the difference.
Currently your editor itself supports hdr, so no need to go into a build to see the effect.
Whether it is displaying correctly is hard to know for me.
There are many different displays, color ranges, nits.
Dont forget though that that is the editor itself.
If you use unreal for a movie it should capture correctly but if you use it for a game
you still need to set hdr for the player through blueprint/code.

It’s sort of confusing for me. When enabled in editor preferences it seems to only look correct when I hit play, otherwise the colors appear blown out. Does it need to be displayed through a camera to display correctly? Some projects that I test this out in by enabling in editor preferences it doesn’t appear to be enabled at all.

I have a HDR monitor since my old monitor stopped working and I had to buy a new one and almost all gaming monitors came with Display HDR / adaptive sync options. I can clearly see the difference on youtube HDR videos but by following the steps above I see no difference. I tried both setting up the blueprints above and enabling the ‘enable editor support for HDR’ option and vice versa but it made no difference and is clearly stuck in LDR mode. I am rendering the default chair scene with a HDR from hdri haven. I expect the sun to be much brighter than it is. I’ve tried various hdrs. The difference in white levels between a HDRyoutube movie trailer video and what I am seeing in UE5 is huge, indicating no HDR in ue5.

What should I do?

Hi. This is working for me. I’m using a widget with a bool to control the HDR and a slider to control it’s nits.

Initiating the HDR widget:

Initiating the nits widget:

Binding the HDR:

Use this after it to know if it’s working:

Binding the nits slider:

There must be better ways to do it. I’m sharing in the hopes that someone gives a better solution.


I’m late to the party here but I’m very interested in how you created this blueprint. I’ve never made a blueprint before. Thanks