Download

How do I distance cull a blueprint spline road?

I have a blueprint spline that is assigned a road mesh done similarly as in the UE Spline and Spline Mesh Components twitch video except mine places meshes based on spacing and not one per spline segment. I have a Cull Distance Volume but it doesn’t seem to be affecting the spline meshes. Is it possible to get parts of this spline road to be culled out by the CDV?

Currently, it doesn’t look like anything is being culled. The CDV is working with the static meshes, which are bigger in size so I don’t think the size I set is too small. I’ve also tried putting down a spline that is short in case the length of the spline is included when comparing the size. In the blueprint under Spline component -> Rendering -> LOD, Allow Cull Distance Volume is checked which, unless I misunderstood, is supposed to mean the spline will be affected by the CDV.

As mentioned in this AnswerHub post, I also tried setting the Desired Max Draw Distance to something small, like 10, just to see what would happen and the spline is still not being culled out.

Am I missing something?

For anyone viewing this in the far future, check whether your editor scalability settings are on Cinematic. If you have that quality enabled and do not enable Game View (G), nothing will ever cull in the viewport.

After constructing your SplineMeshComponent in the blueprint, or in C++, you must set the LDMaxDrawDistance on each of the SMC’s you place on each segment.
If you set the MaxDrawDistance on your Spline itself, it does not affect the SplineMeshComponents that are dynamically constructed and placed on the spline.

Hey alwynd~

Thank you for sharing this piece of information, which saves me a lot of time! =)