How do I disable cross-hairs and get my controls working in my packaged Oculus Rift project?

Hey guys, I have a few problems with the oculus rift when using it with my packaged game.

When playing, the cross-hair is slightly offset. Is there any way I can get rid of the cross-hair completely? I’m using the default blueprint first person.

Also, in the packaged game, WASD or the mouse will not move my controller and I am stuck in place.

Help would be greatly appreciated!

Hey homelesspie,

The crosshair is enabled in the MyHUD Blueprint in the FPS template. In the Event Graph, you can detach the wire between the Event Receive Draw HUD node and the Draw Texture node to disable it. If you’d prefer, you can also add an offset to compensate for the texture’s position (the Blueprint is placing the texture in the center of the screen, but the texture is not centered).

For your controls: have you made any modifications to the player controls? Do they work as intended when you Play in Editor?

Best,

Ben Halliday