How do I disable collision on an scene component?

I have hundreds of very similar objects that get placed dynamically so I have a Blueprint that contains a bunch of different meshes.

In my construction script I iterate through the scene components and make the ones I don’t want invisible.

This all seems to work fine and when I place the Blueprint in a level and type in the name of the mesh I want to display everything looks fine. In the screen shot below I’ve decided to show the “Step_Up_001” mesh.

It looks great doesn’t it?

However, I noticed that even with a single object in the level with l I was having difficulty moving around and also having a hard time selecting them with the “ActorBeginCursorOver” event.

Eventually I turned on “Show Collision” and was horrified to see that all the collision meshes were active, i.e. making a scene component invisible doesn’t turn off the collision mesh as I thought it would.

I swiftly open the Blueprint with the intention of adding a “Set Collision” node for each scene component.

But there isn’t one!

Obviously I’ve Googled about for a few hours but I haven’t found anything useful. In the past when this has happened it’s usually been because there is a better way to do what I’m trying to do.

Is there a way to turn off scene component collisions from a Blueprint- or should I be doing something different?

All help gratefully received.

This should work for component and actors:


Scene components have no collision:

Thanks for looking at my problem and your quick reply. I was hoping to use “Set Collision Enabled” but that node isn’t available to a Scene Component Object Reference (see image below).