How do i disable anim notify on particular skeletal mesh?

I have FPS character, my game is multiplayer, i made notifies for footsteps, but i have 3 the same skeletal meshes, for fps legs, for correct fps shadow and for visibility from another client. They all have the same animbp because of it footstep sound plays 3 time. So how do i disable anim notify on particulasr skeletal mesh? Or maybe there is another way to reach it?