How do I create a One Way Blocking Volume? (where a player can’t pass through but enemies can)

I’m using a hollow blocking volume to contain the player character in a game boundary. I have enemies that spawn outside of the blocking volume but I want them to be able to pass through it (but at the same time not allowing the player to leave the area).

I’ve tried adding Object Collision channels but that doesn’t seem to have any effect.

I’ve looked at other people’s posts and they are related to 2D platformers that require the player to overlap dynamic in mid-air, however if I did that to the enemies in my project they would fall through the floor.

Has anyone overcame this issue or able to point me in the right direction?

Posted by user illYay:

This still works with per polygon collision. You can create a basic quad mesh and in the collision properties of that mesh set it’s collision to use complex collision for simple. It’ll now do per poly collision and let you travel through the backfaces. I’m not sure if there’s a more elegant solution.

Perhaps you can give this a shot. I don’t believe any of the default trigger volumes do that for you. I might tackle that as a pet project and create a 1-way blocking volume…

Hello SuperJee,

Shohei’s idea would be good for a one-way blocking volume, but from what you’re describing, this may be much simpler. If you want the player to never be able to go through this blocking volume but would like enemies to be able to, you could set up custom collision channels to take care of this for you.

If you create a new custom channel called “PlayerBounds” or whatever is appropriate and then set the Player’s collision settings to Block in response to this channel, while the enemies are set up to Ignore in response to it, it should give the behavior you’re looking for.

Custom collision channels can be created in your Project Settings under Collision.

Doesn’t work for me… UE 4.26.2

Do I need to create new collision objects for this for this to work?

I tried everything, but nothing works… I don’t understand why! Only when I choose ignore collision for pawn, physics body and vehical, my enemies can move through the wall, but hero can move too with theese settings…