How do I change how quickly my character slows down?

I have a simple blueprint set up that sets my character to max velocity right away while in movement mode: Flying.

He takes off, but then slows over time until he’s stopped. I want to change the value that causes him to slow down, but cannot find where it is.

Do you have any screenshots of what you are doing? Maybe this helps.

All those values set up are in regards to pawns. I’m dealing with the Character Movement Component.

It’s definitely in the character movement component of your character.

There are a few things regarding friction but I’m not sure if that applies to flying. Check around in the settings for the CMC (Character Movement component)!

Why wouldn’t the nodes / programming (method to control speed) in the flying sample be used with a character class? The character class has additional defaults that do more things then the pawn… so, if the pawn has the speed functionality, they should work in the character. Load up the flying sample…

Have you tried editing the BrakingDecelerationFlying value on the character movement component? That should handle this :slight_smile: